XF 2.2 Cannot call method first on a non-object (NULL)

Manh Do

Member
I keep getting this error message, I don't understand what caused them

ErrorException: Template error: Cannot call method first on a non-object (NULL)
src/XF/Template/Templater.php:963
Generated by: Unknown account
11/11/20 lúc 12:30

Stack trace​

#0 [internal function]: XF\Template\Templater->handleTemplateError(512, 'Cannot call met...', '/home/nginx/dom...', 963, Array)
#1 src/XF/Template/Templater.php(963): trigger_error('Cannot call met...', 512)
#2 internal_data/code_cache/templates/l2/s9/public/thread_list_macros.php(54): XF\Template\Templater->method(NULL, 'first', Array)
#3 src/XF/Template/Templater.php(694): XF\Template\Templater->{closure}(Object(XF\Template\Templater), Array, Array)
#4 internal_data/code_cache/templates/l2/s9/public/forum_view.php(377): XF\Template\Templater->callMacro('thread_list_mac...', 'item', Array, Array)
#5 src/XF/Template/Templater.php(1294): XF\Template\Templater->{closure}(Object(XF\Template\Templater), Array)
#6 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('forum_view', Array)
#7 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#8 src/XF/Mvc/Dispatcher.php(418): XF\Mvc\Renderer\Html->renderView('XF:Forum\\View', 'public:forum_vi...', Array)
#9 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#10 src/XF/Mvc/Dispatcher.php(360): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#11 src/XF/Mvc/Dispatcher.php(53): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#12 src/XF/App.php(2177): XF\Mvc\Dispatcher->run()
#13 src/XF.php(390): XF\App->run()
#14 index.php(20): XF::runApp('XF\\Pub\\App')
#15 {main}

Request state​

array(4) {
["url"] => string(37) "/forum/forums/cho-linh-tinh.42/page-3"
["referrer"] => bool(false)
["_GET"] => array(1) {
["/forum/forums/cho-linh-tinh_42/page-3"] => string(0) ""
}
["_POST"] => array(0) {
}
}
 

Brogan

XenForo moderator
Staff member
That is most likely due to a third party add-on (or style).

If you have just upgraded to 2.2 you will need to ensure all third party add-ons and styles are updated with compatible versions.
 
Top