Fixed Broken oEmbed medium after ugrade to 2.2.10

dave3

Member
Affected version
2.2.10
Hi,

just updated XF to the latest release, but after that all of my oEmbed on my forum are broken. When I browse my threads I am getting following info: Oops! We ran into some problems. Please try again later. More error details may be in the browser console. The console of my browser says:

Code:
Failed to load resource: the server responded with a status of 500 ()
/threads/xenforo-2-2-10.40/#post-122:1 Uncaught SyntaxError: Unexpected end of JSON input
    at JSON.parse (<anonymous>)
    at e (core-compiled.js?_v=1aa515b2:142:75)
    at XMLHttpRequest.onprogress (core-compiled.js?_v=1aa515b2:142:320)
core-compiled.js?_v=1aa515b2:42 PHP:
An exception occurred: [ErrorException] [E_WARNING] array_column() expects parameter 1 to be array, bool given in src/XF/Http/Reader.php on line 321
#0 [internal function]: XF::handlePhpError(2, '[E_WARNING] arr...', '/usr/home/dawid...', 321, Array)
#1 src/XF/Http/Reader.php(321): array_column(false, 'ipv6')
#2 src/XF/Http/Reader.php(106): XF\Http\Reader->isRequestableUntrustedUrlExtended('https://xenforo...', NULL, NULL)
#3 src/XF/Http/Reader.php(81): XF\Http\Reader->requestUntrusted('get', 'https://xenforo...', Array, NULL, Array, NULL)
#4 src/XF/Http/MetadataFetcher.php(56): XF\Http\Reader->getUntrusted('https://xenforo...', Array, NULL, Array, NULL)
#5 src/XF/Service/Unfurl/Fetcher.php(22): XF\Http\MetadataFetcher->fetch('https://xenforo...', NULL)
#6 unfurl.php(71): XF\Service\Unfurl\Fetcher->fetch()
#7 {main}

There were no errors while upgrading, also new threads with oEmbed shows me same error. The links come from this board but I tried also with different URLs and the issue is same. I use PHP v 7.3.32.
 
Last edited:

dave3

Member
Looks like only links to different forums, news sites, etc. are broken. Links to medium like youtube, facebook work fine.
 

dave3

Member
All of my addons are related to default style but I gave it a try and disabled all of them - unfortunately, no results.
 

Anatoliy

Well-known member
All of my addons are related to default style but I gave it a try and disabled all of them - unfortunately, no results.
well, then it means that xF developers made it on purpose that everyone's forum will work fine after upgrade, but yours will have broken links.
 

Brogan

XenForo moderator
Staff member
If this was a general bug with the release I would have expected more reports.

Can you link to a thread/post which is exhibiting the problem.
 

Brogan

XenForo moderator
Staff member
Run the file health check in the ACP to confirm all files are correct.

Then run a rebuild at /install to see if that helps.

What version of PHP is running?
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XF release (2.2.11).

Change log:
Always default to an empty array when IPv6 lookup fails
There may be a delay before changes are rolled out to the XenForo Community.
 

dave3

Member
Hi Jeremy P,

thank you for your answer. I will give it a try today. It looks very promising.

Greetings.

Edit: The fix works, thanks.
 
Last edited:
Top