XF 1.2 Botched FTP upload. Trying to connect to existing DB

Joshua

Active member
So I screwed up when I was trying to use Transmit for my FTP client. I didn't have Transmit "merge" the upgrade package and it instead "replaced" directories. I'm re-uploading the full 1.2 XF install package but how can I bypass the setup stages and connect to the existing and un-changed database?
 

Jeremy

Well-known member
You'll need to set up the config.php again. Using your old settings will automatically pick up the database.
 

Joshua

Active member
OK, that's what I thought. I'll just go in and manually edit the config file so no installation processes are initiated
 

Joshua

Active member
config file has been updated.
Index still says "The board is currently being upgraded. Please check back later."
/install/ Wants to begin installation and wipe the DB.

Now what?
 

Joshua

Active member
Replaced install-lock file in internal_data
Still "The board is currently being upgraded. Please check back later."
 

Joshua

Active member
How can I run the upgrade aside from going to /install/?
When i go to /install/ it says "You have already completed installation. If you wish to reinstall, please delete the file internal_data/install-lock.php."
I'm stuck in a loop.
 

Jeremy

Well-known member
Can you PC me admin details and the link to your forum so I can get a better look into this for you?
 

Joshua

Active member
I appreciate the offer, @King Kovifor but I got some help from a friend. The site is back up though it looks like I may have to re-install add-ons...
 

Joshua

Active member
You were right! I reuploaded the add-on files, disabled and re-enabled them and we're back up and running. What a headache for a couple hours
 
Top