[bd] Attachment Store [Deleted]

Xon

Well-known member
The XF2 version of this add-on can result in unexpected data loss as in some failure cases it will return false instead of throwing an exception in putStream function this add-on extends

This is because the XenForo function copyFileToAbstractedPath doesn't actually check the return result, and very few parts of the XF code check this function's return result and assume it throws.
 
Last edited:

xfrocks

Well-known member
This resource has been removed and is no longer available. The following reason was provided:
This resource has been deleted by XenForo Ltd. in line with our resource housekeeping criteria.
 

fly

Well-known member
It must have been in the original resource maybe?

If memory serves me, you just have to copy it all back locally via SSH, then disable the plugin.
 

cjwinternet

Active member
Apparently "there's a tool" to switch back to local attachments. Damned if I can figure out what or where it is though. I've got all the original files, but can't see anything.
 

cjwinternet

Active member
One more point of concern; When the images are importing back to the server, do they automatically delete from the CDN after they are copied?
 

cjwinternet

Active member
So, we moved server, imported database, and files, tested everything, went to run xfrocks "Update attachment storage options" and nothing. Not a single image imported, not a single file path changed. Really really annoyed. All images are still being served from the CDN.

Bogus message after a few minutes rather than a few days...
 

Attachments

  • Screenshot_1.png
    Screenshot_1.png
    29.2 KB · Views: 16
Top