• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Attachment

Jake Bunce

XenForo moderator
Staff member
#2
It should be opacity: 1 when it finishes uploading. How can I reproduce the problem? Do you have this problem in all browsers? If you can give me a login and URL for your forum then I can test it.
 

Jake Bunce

XenForo moderator
Staff member
#5
Admin CP -> Appearance -> Templates -> attachment_editor_attachment

Near the bottom, add the red code:

Code:
	<div class="AttachmentText">
		<div class="Filename"><a href="{xen:link attachments, $attachment}" target="_blank">{$attachment.filename}</a></div>
	
		<xen:if is="{$isTemplate}">
			<input type="button" value="{xen:phrase cancel}" class="button smallButton AttachmentCanceller" />
			
			<span class="ProgressMeter"><span class="ProgressGraphic">&nbsp;</span><span class="ProgressCounter">0%</span></span>
		<xen:else />
			<noscript>
				<a href="{xen:link 'attachments/delete', $attachment}" target="_blank" class="button Smallbutton">{xen:phrase delete}</a>
			</noscript>
			
			<xen:if is="{$attachment.thumbnailUrl}">
				<div class="label">{xen:phrase insert}:</div>
			</xen:if>
			
			<div class="controls">				
				<input type="button" value="{xen:phrase delete}" class="button smallButton AttachmentDeleter" data-href="{xen:link 'attachments/delete', $attachment}" />
			
				<xen:if is="{$attachment.thumbnailUrl}">
					<input onclick="$('li#attachment{$attachment.attachment_id}').attr('style','opacity:0.1');" type="button" name="thumb" value="{xen:phrase thumbnail}" class="button smallButton AttachmentInserter" />
					<input onclick="$('li#attachment{$attachment.attachment_id}').attr('style','opacity:0.1');" type="button" name="image" value="{xen:phrase full_image}" class="button smallButton AttachmentInserter" />
				</xen:if>
			</div>
		</xen:if>

	</div>
	
</li>
Now the whole attachment row inside of the editor will go "less opaque" when you click Thumbnail or Full Image.