1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 are Prefixes names being indexed by Search-Engines?

Discussion in 'XenForo Questions and Support' started by erich37, Jan 9, 2012.

  1. erich37

    erich37 Well-Known Member

    I have about 50 different Prefixes and wondering if the wording of the Prefixes is being indexed by Search-Engines? The Prefixes actually do have an ID, but not the name itself included... so I am not sure if Prefix-words are indexed ?

    Many thanks!
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yes, thread prefixes are indexed. For example, this thread has a prefix of "1.1" which is seen by search engines.
    14DH01 likes this.
  3. 14DH01

    14DH01 Active Member

    Sorry about the up, but you answered my requests.
    How to make the prefixes are not taken into account?
    I am looking for a way to not include prefixes in securities subject to the search engines.
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Admin CP -> Appearance -> Templates -> thread_view

    Add the red code near the top:

    <xen:title><xen:if is="!{$visitor.is_robot}">{xen:helper threadPrefix, $thread, escaped}</xen:if>{$thread.title}{xen:helper pagenumber, $page}</xen:title>
    <xen:h1>{xen:helper threadPrefix, $thread}{$thread.title}</xen:h1>
    That should hide prefixes from page titles inside of threads. But search engines usually don't like it when you change the content just for them. It's called cloaking. This is a minor change, but it's something to be aware of.
    14DH01 and Digital Doctor like this.

Share This Page