• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Apple App Store BBcode - ThemesCorp.com [Deleted]

#10
I get the following error message in the xenForo backend each time someone is opening/refreshing a rss feed containing a posting with the app store bbcode:

ErrorException: Array to string conversion - library/ThemesCorp/AppleAppStoreBBCode/Callback.php:42

#0 /xenforo/library/ThemesCorp/AppleAppStoreBBCode/Callback.php(42): XenForo_Application::handlePhpError(8, 'Array to string...', '/kunden/87690_2...', 42, Array)
#1 [internal function]: ThemesCorp_AppleAppStoreBBCode_Callback::renderTagApple(Array, Array, Object(SolidMean_ComprehensiveURLParser_BbCode_Formatter_Base))
#2 /xenforo/library/XenForo/BbCode/Formatter/Base.php(745): call_user_func(Array, Array, Array, Object(SolidMean_ComprehensiveURLParser_BbCode_Formatter_Base))
#3 /xenforo/library/XenForo/BbCode/Formatter/Base.php(652): XenForo_BbCode_Formatter_Base->renderValidTag(Array, Array, Array)
#4 /xenforo/library/XenForo/BbCode/Formatter/Base.php(565): XenForo_BbCode_Formatter_Base->renderTag(Array, Array, 0)
#5 /xenforo/library/XenForo/BbCode/Formatter/Base.php(546): XenForo_BbCode_Formatter_Base->renderTreeElement(Array, Array, 0)
#6 /xenforo/library/XenForo/BbCode/Formatter/Base.php(526): XenForo_BbCode_Formatter_Base->renderSubTree(Array, Array)
#7 /xenforo/library/XenForo/BbCode/Parser.php(505): XenForo_BbCode_Formatter_Base->renderTree(Array, Array)
#8 /xenforo/library/XenForo/ViewPublic/Forum/GlobalRss.php(47): XenForo_BbCode_Parser->render('F\xC3\xBCr kurze Zeit...', Array)
#9 /xenforo/library/XenForo/ViewRenderer/Abstract.php(227): XenForo_ViewPublic_Forum_GlobalRss->renderRss()
#10 /xenforo/library/XenForo/ViewRenderer/Rss.php(31): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Rss', Array, '')
#11 /xenforo/library/XenForo/FrontController.php(601): XenForo_ViewRenderer_Rss->renderView('XenForo_ViewPub...', Array, '', NULL)
#12 /xenforo/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_Rss), Array)
#13 /xenforo/index.php(13): XenForo_FrontController->run()
#14 {main}

array(3) {
["url"] => string(40) "/forum/-/index.rss"
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}
 

Allan

Well-known member
#11
I get the following error message in the xenForo backend each time someone is opening/refreshing a rss feed containing a posting with the app store bbcode:

ErrorException: Array to string conversion - library/ThemesCorp/AppleAppStoreBBCode/Callback.php:42

#0 /xenforo/library/ThemesCorp/AppleAppStoreBBCode/Callback.php(42): XenForo_Application::handlePhpError(8, 'Array to string...', '/kunden/87690_2...', 42, Array)
#1 [internal function]: ThemesCorp_AppleAppStoreBBCode_Callback::renderTagApple(Array, Array, Object(SolidMean_ComprehensiveURLParser_BbCode_Formatter_Base))
#2 /xenforo/library/XenForo/BbCode/Formatter/Base.php(745): call_user_func(Array, Array, Array, Object(SolidMean_ComprehensiveURLParser_BbCode_Formatter_Base))
#3 /xenforo/library/XenForo/BbCode/Formatter/Base.php(652): XenForo_BbCode_Formatter_Base->renderValidTag(Array, Array, Array)
#4 /xenforo/library/XenForo/BbCode/Formatter/Base.php(565): XenForo_BbCode_Formatter_Base->renderTag(Array, Array, 0)
#5 /xenforo/library/XenForo/BbCode/Formatter/Base.php(546): XenForo_BbCode_Formatter_Base->renderTreeElement(Array, Array, 0)
#6 /xenforo/library/XenForo/BbCode/Formatter/Base.php(526): XenForo_BbCode_Formatter_Base->renderSubTree(Array, Array)
#7 /xenforo/library/XenForo/BbCode/Parser.php(505): XenForo_BbCode_Formatter_Base->renderTree(Array, Array)
#8 /xenforo/library/XenForo/ViewPublic/Forum/GlobalRss.php(47): XenForo_BbCode_Parser->render('F\xC3\xBCr kurze Zeit...', Array)
#9 /xenforo/library/XenForo/ViewRenderer/Abstract.php(227): XenForo_ViewPublic_Forum_GlobalRss->renderRss()
#10 /xenforo/library/XenForo/ViewRenderer/Rss.php(31): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Rss', Array, '')
#11 /xenforo/library/XenForo/FrontController.php(601): XenForo_ViewRenderer_Rss->renderView('XenForo_ViewPub...', Array, '', NULL)
#12 /xenforo/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_Rss), Array)
#13 /xenforo/index.php(13): XenForo_FrontController->run()
#14 {main}

array(3) {
["url"] => string(40) "/forum/-/index.rss"
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}
With XenForo 1.4 ou 1.5 ?