• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Anyone use Ubuntu? Keyboard mapping issue...

Liam W

Well-known member
#1
Can anyone tell me how to make the @ key actually put an @ symbol in? Currently it puts a " symbol in and the " key puts and @ symbol in...

It's really annoying, and the strangest part is, UK is the only keyboard layout listed in settings...

Liam
 

Tracy Perry

Well-known member
#2
Can anyone tell me how to make the @ key actually put an @ symbol in? Currently it puts a " symbol in and the " key puts and @ symbol in...

It's really annoying, and the strangest part is, UK is the only keyboard layout listed in settings...

Liam
Just for giggles, have you tried changing it to a US keyboard and see if that works?
Also, wired keyboard or wireless? If wired, have you tried changing to a new USB port on the computer?
Is this happening in Terminal or in the Windows Manger you have installed?
 

Teapot

Well-known member
#3
US keyboards (and Mac layouts) have @ as the Shift-2 key anyway, but switching to US then back to the standard UK keyboard layout might kick it into using the correct keymap.