1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Anyone good with server configs and Memcached?

Discussion in 'Server Configuration and Hosting' started by Glockie, Jun 12, 2015.

  1. Glockie

    Glockie Well-Known Member

    I have a server issue and am hoping for some help... :(
    I managed to go so far with everything, but we just cannot get memcached going.

    I'm running Ubuntu 14.04, PHP 5, and it won't have any of it.
    I can install the server for memcached (now removed) but not the PHP side of it.

    This is the error, which points to changing the PHP version to a lower one;
    Code:
        The following packages have unmet dependencies:
    php5-memcached : Depends: php5-common (= 5.3.29-1~dotdeb.0) but 5.5.9+dfsg-1ubuntu4.9 is to be installed
    I've tried many different things, but no joy.
    Spoken with our host DO and they sent me a few things to try but ultimately they weren't sure as after all, they're just the hosts..

    I followed THIS guide and another for 14.02 I think it was, but nothing..

    I actually crashed the server (live) too, which hasn't helped today.
    I'd be most grateful for some help/advice.
    many thanks
     
    Last edited: Jun 13, 2015
  2. Solidus

    Solidus Well-Known Member

    Use the --nodeps flag when using apt-get.
     
  3. Glockie

    Glockie Well-Known Member

    Can you possibly provide an example with the mentioned depends included?
    I've tried it a few ways but it keeps coming back with command not understood (or words to that effect, been a loooong day)
    And thank you!! (y)
     
  4. Solidus

    Solidus Well-Known Member

  5. Glockie

    Glockie Well-Known Member

    Couldn't get this working, but managed to get Zend working fine..
    Does anyone have a good working cache config setting I can use an example please?
    https://xenforo.com/help/cache/
    That page doesn't go into too much detail and I can't really find much info either for Zend on the config files?

    I have this as an idea but unsure really...


    Code:
    $config['cache']['enabled'] = true;
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions'] = array(
    'caching' => true,
    'automatic_serialization' => true,
    'lifetime' => 3600,
    'cache_id_prefix' => ''
    );
    
    $config['cache']['backend'] = '';  
     
  6. Solidus

    Solidus Well-Known Member

    Zend Opcache? There's no config needed. Just make sure things are actually being cached.
    I can set up memcached for you if you like, it works great with Opcache.
     
  7. Glockie

    Glockie Well-Known Member

    I wouldn't say no, if you could/would?
    I am having huge issues doing so.

    Will PC you now, and thank you.
     
  8. Solidus

    Solidus Well-Known Member

    You have Ubuntu 14.04 btw, not 10.04.
     
  9. Glockie

    Glockie Well-Known Member

    Yes, did I list it as 10?
    lol typo probably, will adjust it now. Yes running that with virtualmin. ;)
     
  10. Solidus

    Solidus Well-Known Member

    How large is your forum? I will adjust memcached config accordingly.
     
  11. Glockie

    Glockie Well-Known Member

    In which respect?
    It's fairly new (March) but over 700 members - db 160Mb,
    Couple of GB worth of videos.. same for pics - it's a very busy site, considering we only went live in March;

    Code:
    Discussions:
        343
    Messages:
        3,964
    Members:
        710
    Total Albums:
        168
    Total Photos:
        1587
    Total Videos:
        22
    
    
     
  12. Sheratan

    Sheratan Well-Known Member

    You are using dotdeb repo?
     
  13. Glockie

    Glockie Well-Known Member

    Seems to be so yes.. I think it was from an update required for ffmpeg.
    Hard to shake too, that much I can tell you. So frustrating o_O
     

Share This Page