• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Animated gifs

#1
Hello,

a strange thing happens.
We have this guy with a nasty avatar: https://www.nationaalcomputerforum.nl/threads/films-blijven-hangen.131866/#post-1090568

In Admin for this member I set Avatars on 1kb and updated the permissions.
Even that does not work: as you see, the animated gif is still working.
Stranger is this:
https://www.nationaalcomputerforum.nl/data/avatars/l/165/165923.jpg?1497356639
The link says it is a JPG, download this and it is a gif.


On my own forum there is no problem; animated gifs are only shown in Profile.

So my question is how to disable animated gifs in the forums?
 

Brogan

XenForo moderator
Staff member
#2
You will need to manually delete the avatar after changing the options.

You can also apply individual permissions to that member to prevent them uploading an avatar.
 
#3
Hello Brogan, I already had thought about this solution - but this is for only one user then.
Why is it so different on my own forum, where animated gifs are not shown in the fora and at the NCF they do?
 

Jake B.

Well-known member
#4
Why is it so different on my own forum, where animated gifs are not shown in the fora and at the NCF they do?
If you're using ImageMagick it'll keep the animation on the gif when it is resized/manipulated, with GD it won't. Can probably just switch the image processor to GD in your options if you want to get rid of the animated gifs