Analytics falling off the cliff after https switch

upnet

Active member
We made the scary change from http to https and our Analytics are taking a 2 week nosedive. Strangely though our cPanel AWSTATS are not. Is there any possible explanation for this?
 

Anthony Parsons

Well-known member
We made the scary change from http to https and our Analytics are taking a 2 week nosedive
Yer... but what has declined specifically? Have users declined, OR, all the bad stuff sniffing around your unsecured site? I mean actual users, not the nasties cloaking themselves as users.
 

eva2000

Well-known member
Google Analytics I assume ? check the browser version and profile of your visitors. Sometimes alot of your traffic are bots using old browsers which may not support your server's peferred SSL ciphers so can't visit the site.

My Centmin Mod forum's premium members get acces to custom GA Dashboards I create including ones for browser breakdowns https://community.centminmod.com/posts/25254/. Very handy to see what makes up your real traffic etc. But you can create your own GA custom Dashboards too.

upload_2017-3-6_18-37-31.png

So if the majority of lost traffic is to WinXP IE 8 browser sessions durations of 1-10 seconds, you know you only lost bot/crawler traffic with switch to HTTPS etc :)
 

Live Free

Active member
Somewhat on topic:

I read that Xenforo will automatically detect if you're using http or https and use the proper version of analytics. What I'm wondering is should I be changing the default property URL in GA to the https version? How will this affect my GA data?
 
Top