XF 2.2 Akismet is stopping user's normal non spam post or conversations

Mr Lucky

Well-known member
I have one users's messages in moderation queue saying akismet matched.

How can I find the reason. Nothing in the post should trigger this as far as I can tell.

Code:
Spam trigger log
Action: Moderated Akismet matched
Generated by: xxx Yesterday at 11:16 PM Content: Post
Request state
array(4) {
  ["url"] => string(37) "/threads/crie-de-couer.6910/add-reply"
  ["referrer"] => string(53) "https://cafesaxophone.com/threads/crie-de-couer.6910/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(10) {
    ["_xfToken"] => string(8) "********"
    ["message_html"] => string(1114) "<blockquote data-attributes="member: 7742" data-quote="xxxx" data-source="post: 331061"><p>I have all of his lessons somewhere in a box.</p><p><br></p><p>when I was just starting sax,&nbsp; I lived in the north of scotland and there wasnt a teacher for miles.</p><p><br></p><p>somehow I found out about Leslie Evans&nbsp; ( I think I was looking to upgrade my mouthpiece ) and ended up buying the whole course.</p><p><br></p><p>it helped me greatly,&nbsp; but I never got very far in to it,&nbsp; and certainly not the advanced stuff.</p><p><br></p><p>i do remember the timing stuff being very useful.</p><p><br></p><p>i will see if I can find them,&nbsp; but dont hold your breath.&nbsp; they are in the attic somewhere.</p></blockquote><p>Hi</p><p id="isPasted">&nbsp;I see this post is from a while ago, but do you have Leslie Evans' Advanced Course? I have all his courses, still in punch hole binders, but I've mislaid the advanced (or accidentally thrown out) since a house move a couple of years ago. Of Course I'd reimburse you any reasonable amount for a copies.</p><p>Thanks,</p><p><br></p><p>James</p>"
    ["attachment_hash"] => string(32) "654ae9d3b11a0c5442bb89b0b8daaf57"
    ["attachment_hash_combined"] => string(86) "{"type":"post","context":{"thread_id":6910},"hash":"654ae9d3b11a0c5442bb89b0b8daaf57"}"
    ["last_date"] => string(10) "1667258107"
    ["last_known_date"] => string(10) "1496684963"
    ["load_extra"] => string(1) "1"
    ["_xfRequestUri"] => string(28) "/threads/crie-de-couer.6910/"
    ["_xfWithData"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
 
Last edited:

Mr Lucky

Well-known member
I now find that he cannot send conversations.

I have copied the database to a test installation, so log in as this user and when sending a conversation that is not at all spammy I get this error:

Your content can not be submitted. This is likely because your content is spam-like or contains inappropriate elements. Please change your content or try again later. If you still have problems, please contact an administrator.

If I remove the aksimet API then the conversation sends.

Can anyone please help?
 

jeb35

Well-known member
Has the post been edited? I had one like that awhile back. It was fine when originally posted but then it was edited and then put in approval queue. In fact it was edited multiple times.
 

Mr Lucky

Well-known member
Yes the two posts had been edited. So is it merely editing that sends the posts to be be unapproved? That is very odd.

However on the test site the user just could not make a post without it needing approval - so no editing involved.
 
Top