• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

After database import, all my users are "New Member"

#1
So I imported my SMF2 forum in XenForo through phpBB3. Afterwards, I ran this query in phpMyAdmin:

Code:
UPDATE xf_user SET secondary_group_ids = ''
Now, I noticed all regular users show "New Member" as their user group, regardless of what user group they are in. I looked in the database, and in the xf_user table, all "display_style_group_id field entries are "2". This is their primary user group, but I want this to be their secondary user group. I set up several user group promotions, and most of my users have been promoted, but the promoted user group doesn't show up as a user title. They're still "New Member". What could be problem here?
 
F

Floris

Guest
#2
Rebuild all the caches
Run all the cron entries

Does it still happen?

When you have a usr showing the wrong value, open up their profile, do they have a custom entry for it, or does their usergroup populate it?

Are they in multiple usergroups?
 
#4
Rebuild all the caches
Run all the cron entries

Does it still happen?

When you have a usr showing the wrong value, open up their profile, do they have a custom entry for it, or does their usergroup populate it?

Are they in multiple usergroups?
I rebuild the caches and ran the crons. Still happens.

User groups populate their user title (I disabled custom user titles).

Yes, they are in multiple user groups: primary user group is "Registered", secondary user group varies (I want the user titles of this secondary group displayed on their profiles.

You really should be following the recommended configuration, which is to have all users in the Registered user group as their Primary.
That is the way I have it setup, all of these users have Registered as their primary group.
 
F

Floris

Guest
#5
display styling registered: 0
display another one: higher than 0.

That's what I do on my site.
So secondary usergroup custom usertitles overwrite 'new member'.
 
#6
Well, that is how I have it setup as well. And all other user groups have a User Title Override, but these do not show.
 

Jake Bunce

XenForo moderator
Staff member
#7
So I imported my SMF2 forum in XenForo through phpBB3. Afterwards, I ran this query in phpMyAdmin:

Code:
UPDATE xf_user SET secondary_group_ids = ''
That query is a potential problem for two reasons that I know of:

1) xf_user.permission_combination_id must also be updated. This value is normally calculated by the software when you edit a user through the Admin CP.

2) xf_user_group_relation must also be updated.

I always advise people to make group changes through the Admin CP to ensure that all relevant tables and columns are updated.

Regarding the problem with user titles, this thread might help:

http://xenforo.com/community/threads/trophy-user-titles-issue-after-import.6973/
 
#8
Rebuilding user caches doesn't help. As far as I know, everything is set up correctly on the Admin CP side. Somehow xf_user.display_style_group_id is not being updated when either cron jobs or renewed caches kick in. It is the same value for everyone. (Exept moderators and the administrator.)
 

Jake Bunce

XenForo moderator
Staff member
#9
Rebuilding the user cache should update the display group.

I can take a look if you are comfortable giving me admin access to your forum.
 
#10
Rebuilding the user cache should update the display group.

I can take a look if you are comfortable giving me admin access to your forum.
I'll send you a personal message then. But rebuilding user cache does not solve the problem, because I tried it a few times without result.