XF 2.2 Admin user_edit secondary usergroups not displaying as expected


XF v2.2.12
PHP version: 8.1.13
MySQL version: 8.0.30 (8.0.30-22)
Server software: nginx/1.23.3
Addons: Xon's redis addon, currently disabled

When editing a user in the Admincp, the checkboxes for secondary group ids show up empty (unticked), saving a user in this state removes previously existing secondary group ids.

* Verified that the user entity does indeed have the group(s) assigned via xdebug:
Groupid 9 corresponds to "Contributor"

As it shows up in AdminCP:
Contributor box is not ticked.

Saving the user in this state removes the Contributor group as can be confirmed in the user history:

What was tried:
* It was tried to add a {{ dump($user) }} into the user_edit admin template but the edit request was 401 denied. This could be because of our security configuration. No further template edit was attempted.
The Master templates were not changed from a stock xenforo installation.

* A new user was created in the AdminCP and assigned two random secondary user roles, the same symptom occured where the assigned secondary user roles were not visible and saving the user in that state removed the secondary user roles.

What can be done about this?
So a fix i found is to strval the array in
, but making code changes like that is obviously not ideal

I suspect something server side is involved (or some other code) - we have had no other reports of this.

Can you repro it in a demo instance?

Its very likely a combination of custom code and specific server versions, so if i'm unable to control php version and extensions running on the server, the xf demo wont help here

We are also running MariaDB which does not support MyISAM tables, so we had to get rid of all those tables, might not be related but that gives you an idea how uncommon our setup could be
Top Bottom