1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Adding custom HTML/PHP

Discussion in 'XenForo Questions and Support' started by poketjjax, Aug 17, 2013.

  1. poketjjax

    poketjjax New Member

    hey guys,
    i'm new to xenforo, but i wanted to add some custom html and php to some of my pages. i added the code through FTP but it never showed up on the page. am i doing something wrong?

    i've tried adding code to both the admin page and the regular forum page and neither worked.

    thanks in advance for the help!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. poketjjax

    poketjjax New Member

    i was trying to add the code to the admin control panel page which is located at /forum/admin.php for me. also wanted to add code to the main home page with is /forum/index.php.
     
  4. poketjjax

    poketjjax New Member

    well i have tried a few things with no luck. i tried debugging mode which for some reason only seems to change the page content when i intentionally make an error. for example if i leave a semicolon off then an error message is displayed. if i type something like echo "testing!!"; the changes won't show up at all.

    i also tried the callback method that was suggested, but my xenforo version is 1.1.5 and from what i read the callback only works for 1.2

    any other suggestions? i don't get why it's so difficult to edit html and css through an FTP log in...
     

Share This Page