XF 1.5 ACP search not working [Desktop]

Pixel Squad Ltd

Active member
Hello all,

Yesterday I installed an add-on which conflicted with another add-on and took my website down.

I managed to fix it after removing the conflicting add-on through the FTP, but since then, my ACP search won't work on desktop. It works as intended on mobile version.

When I hover over "Search" on desktop, the cursor changes to recognise there is a clickable link there, but when I click it the bar which usually shows up below, isn't coming up.

Can anyone suggest a fix for this? I hope I don't have to do I full install of Xenforo again.

Regards,
Carl
 

xenfans

Well-known member
o_O, how did you uninstall the addon (which one) through FTP
It really isn't just removing the .php files to be honest.

Maybe try:
https://xenforo.com/help/config-php-options/
Turn off add-ons temporary, maybe set the site to inactive for this.
Put the FTP files back, and go to list of add-ons and properly remove the add-on.
Then enable listeners again and set the site to active.

See if search works again now.
 

Pixel Squad Ltd

Active member
o_O, how did you uninstall the addon (which one) through FTP
It really isn't just removing the .php files to be honest.

Maybe try:
https://xenforo.com/help/config-php-options/
Turn off add-ons temporary, maybe set the site to inactive for this.
Put the FTP files back, and go to list of add-ons and properly remove the add-on.
Then enable listeners again and set the site to active.

See if search works again now.
I just deleted the files, so I don't have a copy of the files unfortunately. The add-on was [TH] Login As User for the files I deleted, but the add-on I installed was [tlk] Thread Count.

I deleted all the [TH] Login As User file's, as this was the one with the error. Uninstalled Thread Count through ACP and reinstalled Login As User

Would it not be possible to copy and paste the search function code?
 

xenfans

Well-known member
Just removing the files doesn't uninstall the add-on from xenforo. That's why you have to install it in the first place. The files are just helpers to get the plugin to do what it needs to do.
 
Top