[8WR] Ultimate Random Header

[8WR] Ultimate Random Header 1.0.0

No permission to download

Chuck Day

Member
Random works great. Thanks for the add-on.

Nodes doesn't work for me though. It's not passing the variable value to header.php. I wrote a debug log and it's passing:

node={$quickNavSelected}
 

51463

Well-known member
I want to install this but the instructions don't explain how to. It just says upload the folder... then what?

Are we supposed to edit something?

I am guessing for each node i will upload each logo to the nodes folder

then configure the header.php? I looked inside it but im not sure where exactly i am supposed to

I want to have a different logo in each node forum

help!:(
 

Zelkova

Member
Random works great. Thanks for the add-on.

Nodes doesn't work for me though. It's not passing the variable value to header.php. I wrote a debug log and it's passing:

node={$quickNavSelected}


I too am having no problem with random.
But when I try to designate a node I have problems. I have tried the following naming schemes

1SJFuRD.png


None of these have resulted in the header changing for just this one node.
 
Last edited:

Zelkova

Member
You cant have it in the CSS. It must be in the HTML.

I have not attempted to change the header with CSS at all.

I am simply telling the settings that my header image is "styles/header/header.php?node={$quickNavSelected}&user={$visitor.customFields.header}" as was suggested.
Random works fine. Dictated nodes is not.

d8pymMS.png
 

electrogypsy

Well-known member
i'm guessing that the naming scheme for nodes changed sometime between xf 1.2 and 1.4, but i could be wrong. i can't get nodes to work either.
 

electrogypsy

Well-known member
I want to install this but the instructions don't explain how to. It just says upload the folder... then what?

Are we supposed to edit something?

I am guessing for each node i will upload each logo to the nodes folder

then configure the header.php? I looked inside it but im not sure where exactly i am supposed to

I want to have a different logo in each node forum

help!:(

follow the instructions. upload the files, then use the link where you want the image to appear.
 

51463

Well-known member
It doesn't say where exactly to put the link and are we supposed to edit the header.php file?

This is what i did.

1. I downloaded the file
2. Uploded it via ftp
3. uploaded a .png file in the nodes folder called: off-topic-8.png
4. went to this link:
http://thebiggestforums.com/community/index.php?forums/off-topic.8/

But nothing happened. am i missing a step? i don't know where to put that link. The instructions are not simple
 

Jaxel

Well-known member
I have not attempted to change the header with CSS at all.

I am simply telling the settings that my header image is "styles/header/header.php?node={$quickNavSelected}&user={$visitor.customFields.header}" as was suggested.
Random works fine. Dictated nodes is not.

d8pymMS.png
No... that image is clearly in the CSS. I specifically state in the usage notes:
  • You CAN NOT use this system in the built in XenForo CSS system. XenForo aggressively caches it's CSS files, so the whole semblance of "dynamic" or "random" is just not possible. If you want to use this, such as I have on 8WayRun.Com, you must put the property directly into the element in your templates.
 
Top