1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 500 Error when viewing threads post 1.1.4 upgrade.

Discussion in 'Installation, Upgrade, and Import Support' started by WaddleJrJr, Jul 25, 2013.

  1. WaddleJrJr

    WaddleJrJr Member

    I recently upgraded my site to 1.1.4, and after updating the site, when any user tries to view a thread it gives a 500 error. I tried restoring back to my old version on 1.1.3 via a restore I made before upgrading, but had the same problem all of the sudden. I checked the CHMOD of the data and internal_data folders and confirmed that they are set to 777.

    Does anyone else have any ideas of what to do?

    Edit - I tried updating to 1.1.5 to see if that would do anything. Same issues. Also the error log in Cpanel is blank, so it looks like that won't be providing any help.

    UPDATE: With help from the host support, I have been able to locate the problem. Here is the error -
    [25-Jul-2013 05:14:45 UTC] PHP Fatal error: Call to undefined method XenForo_BbCode_Parser::create() in /home/brajoc/public_html/library/UDS/ViewPublic/Thread/View.php on line 7

    I've checked it out, and went to see if I could find this in a full Xenforo package, but could not find this file's existence in the regular 1.1.5 download. Perphaps that's the problem then. Or not. I also checked out the full Xenforo 1.1.3 package and the file doesn't exist in there either. At this point I'm totally confused to why that file even exists...
     
    Last edited: Jul 25, 2013
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Looks like an add-on to me, as most of the xenForo stuff is in the xenForo library. Disable listeners in your config.php and see if it works then. If so, then look for whatever add-on that is and disable it.

    EDIT: Looks like it may be the Ignore Signature add-on by @Liam W. You may want post in the add-on support area
    http://xenforo.com/community/threads/ignore-signatures.52075/
     
  3. WaddleJrJr

    WaddleJrJr Member

    Yup, I actually just ran through them and discovered the same thing. I'll head right over there and post about it.

    Thank you very much for the help!

    EDIT - It seems the creator has addressed this recently when he stated that it could not be used with the Install and Upgrade Add-on, so that base has very recently been covered, and people should now be aware. So no need to post about it on the add-on support.
     

Share This Page