1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 404 error, copying production site to dev server

Discussion in 'Installation, Upgrade, and Import Support' started by Mouth, Oct 10, 2013.

  1. Mouth

    Mouth Well-Known Member

    I get a '404 Not Found' error on my dev server, after having copied across the XF dir tree and imported the DB from my production server.

    Both servers are running nginx, php-fpm, and mysql.

    I've:
    • compared php and nginx server settings, and all looks OK
    • followed http://xenforo.com/help/friendly-urls/ for nginx
    • ensured chmod 777 on /data and /internal_data
    • user:group is teh same on both servers
    • database connectivity is working fine, tested by using mysql command line and querying XF tables with same login credentials as inside config.php
    • added an index.html to my root XF dir/path to ensure this was loaded, and then removed to only have XF's index.php
    • turned on XF debug mode in config.php
    • disabled all caching in config.php

    Have also checked nginx error.log and nothing is recorded. Nothing in php.log either. nginx access.log shows the request coming through to the server

    Not sure where to go from here ... does XF have it's own debug logs?
     
  2. Liam W

    Liam W Well-Known Member

    Is the index.php file in the root of the htdocs area, and is the nginx configuration correct?
     
  3. Mouth

    Mouth Well-Known Member

    Yes, I believe so.

    Code:
    server {
            listen 80;
            server_name dev;
    
            root /var/www/dev;
            index index.html index.php index.htm;
    
            location / {
                    # First attempt to serve request as file, then
                    # as directory, then fall back to displaying a 404.
                    try_files $uri $uri/ /index.php?$uri&$args =404;
                    # Uncomment to enable naxsi on this location
                    #include /etc/nginx/naxsi.rules;
            }
    
            location ~ ^/(internal_data|library)/(.*)$ {
                    internal;
            }
    
            # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
            #
            location ~ \.php$ {
                    try_files $uri =404;
                    fastcgi_split_path_info ^(.+\.php)(/.+)$;
                    # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
        
                    # With php5-cgi alone:
                    #fastcgi_pass 127.0.0.1:9000;
                    # With php5-fpm:
                    fastcgi_pass unix:/var/run/php5-fpm.sock;
                    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                    fastcgi_index index.php;
                    include fastcgi_params;
            }
    }
    
    Code:
    root@ubuntu-server:/var/www/dev# ls -la
    total 132
    drwxr-xr-x  13 root    root      4096 Oct  9 22:59 .
    drwxr-xr-x  4 root    root      4096 Oct  5 13:55 ..
    -rw-r--r--  1 www-data www-data  1791 Mar 26  2013 admindav.php
    -rw-r--r--  1 www-data www-data  415 Mar 26  2013 admin.php
    -rw-r--r--  1 www-data www-data  363 Mar 26  2013 cron.php
    -rw-r--r--  1 www-data www-data  359 Mar 26  2013 css.php
    drwxrwxrwx  10 www-data www-data  4096 Jan 21  2013 data
    -rw-r--r--  1 www-data www-data  894 Oct 29  2012 favicon.ico
    -rw-r--r--  1 www-data www-data  416 Mar 26  2013 index.php
    drwxrwxrwx  8 www-data www-data  4096 Jan 21  2013 internal_data
    drwxr-xr-x  41 www-data root      4096 Apr 16 00:20 js
    drwxr-xr-x 114 www-data root      4096 Jun 14 14:02 library
    -rw-r--r--  1 www-data www-data 18249 Dec 24  2012 logo.png
    -rw-r--r--  1 www-data www-data  327 Dec 24  2012 opensearch.xml
    -rw-r--r--  1 www-data www-data  1025 Mar 26  2013 rgba.php
    -rw-r--r--  1 www-data www-data    26 Oct  5 14:36 robots.txt
    drwxr-xr-x  22 root    root      4096 Apr 16 00:20 styles
    
     
  4. Liam W

    Liam W Well-Known Member

    And are you going to localhost/dev or localhost?
     
  5. Mouth

    Mouth Well-Known Member

    In essence of your question, http://localhost/

    (But, it's on my home server ..... I use http://dev/ and have a hosts file on localhost for "dev 192.168.100.1" (which is my server))
     
  6. Mouth

    Mouth Well-Known Member

    Ahhh, found it !!

    Code:
    // Disable all Add-Ons
    $config['enableListeners'] = 0;
    Added to config.php and now it works (sans any add-ons functionality). So seems I have an add-on with a problem.

    Thanks for your help, appreciate it.
     

Share This Page