XF 2.2 “Oops! We ran into some problems”—Many members are unable to post

PumpinIron

Well-known member
A large number of my members are unable to post a new thread or respond to an existing thread. When trying to do so they get the following message


1615659597472.jpeg

Nothing shows up in the browser console at all. I thought maybe it was related to the Mod_Security Apache module so I tried disabling that but still no luck.

Any ideas what might be going on?

I am running Sucuri’s WAF (Web Application Firewall) but I don’t have any unusual settings checked or anything like that.
 

Brogan

XenForo moderator
Staff member
Without any error message in the console it's impossible to know the cause.

Most likely it's something server side though, especially if you haven't made any changes to XF prior to it happening.

Try checking the server error log.
 

PumpinIron

Well-known member
Looks like it may be Sucuri after all.

On another page I see this message in the error console:

"An attempted XSS (Cross site scripting) was detected and blocked"

The odd thing is that I don't have this option enabled in Sucuri.

FML. The only reason I am running the Sucuri firewall is because the massive amount of bad bot traffic I am getting which is causing Google AdSense to limit my account and the amount of ads I can show, ultimately dramatically affecting my revenue.
 
Top