PSA: Critical PHP vulnerabilities

Naz

XenForo developer
Staff member
Licensed customer
The PHP security team would like to give advance notice of an upcoming security release.

It is scheduled for Wednesday, 21 October 2026 at 14:00 UTC.

It addresses two critical vulnerabilities, both rated CVSS v4.0 9.2.

All PHP users are encouraged to prepare now so they can upgrade as soon as the release is available.

We reserve the right to release earlier should details of either vulnerability become public, or should evidence of active exploitation appear in the wild.

Full details, affected versions, and the fixed versions will be published with the release.

Thank you for helping us keep PHP secure.

 
 

We still all need to patch our PHP, but at least Cloudflare was on it early enough.
 
Emailed the server to check (shared hosting) - I'm currently showing as on 8.3.35 so looks like it hasn't been done yet - it needs 8.3.36 doesn't it? Good that Cloudflare have put some protection in place but presumably that's not enough?
 
Emailed the server to check (shared hosting) - I'm currently showing as on 8.3.35 so looks like it hasn't been done yet - it needs 8.3.36 doesn't it? Good that Cloudflare have put some protection in place but presumably that's not enough?
Correct on both accounts.
 
What would be a Quick explanation of what the vulnerability is ? Anyone ?
How about reading it yourself?

critical vulnerabilities that can allow unauthenticated remote code execution.


Is is as bad as it can get.

The vulnerabilities:
  • RCE via OOM corruption, CVE-2026-109618 (GHSA-w8hw-w9fx-j79w): out-of-memory handling can interrupt PHP while internal request data is only partially initialized. Request cleanup may then treat the invalid data as valid.
  • RCE via stale global state, CVE-2026-109619 (GHSA-6wmf-4rv5-p3rp): request-owned internal state can survive after its backing memory has been freed. A later request handled by the same worker may use that stale state before normal initialization resets it.
 
Would be nice if we can get an update release for 2.1 that supports PHP 8.0+

I'm not a big fan of the editor on 2.2-2.3, and have been waiting for 2.4. Since a lot of custom built things have to be upgraded, I didn't want to do multiple upgrades.

If that's a possibility @Chris D

Thanks
 
It is not a possibility. Just like it's not a possibility for PHP to release updates for versions below 8.2. There has to be a sensible cut off and the sensible cut off for XF 2.1 was years ago.
 
Here, ChatGPT helped a researcher find a PHP vulnerability and patch it

To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
 
It is not a possibility. Just like it's not a possibility for PHP to release updates for versions below 8.2. There has to be a sensible cut off and the sensible cut off for XF 2.1 was years ago.

I've applied the workarounds, will still wait out for 2.4.
 
Whilst we're waiting for our shared hosting provider to apply the patch, is there a way that we can take the site offline such that the vulnerability is not exposed?
 
Whilst we're waiting for our shared hosting provider to apply the patch, is there a way that we can take the site offline such that the vulnerability is not exposed?
On Cloudflare you can set an "under maintenance" snippet which basically blocks the site with a 503 and displays a message saying whatever you change the html to say (it populates a standard one about site under maintenance). As part of that you set a rule and can put in the custom expression

http.host contains "forumname.com" and not ip.src eq xxxxxxxx (xxxx being your IP address)

So it blocks everything except your IP. So you can keep checking acp to see when the php version changes.

I've just taken mine offline that way. Apparently 503 is better for Google than 403.

Presumably your host has mitigations in place. Mine says it has but not comfortable about relying on that after a number of hours.
 
Back
Top Bottom