grahamperrin
Reaction score
3

Profile posts Latest activity Postings About

  • Happily using an early 2009 vintage MacBookPro5,2. Mavericks preferred. I'll get a new MacBook Pro before Yosemite becomes a requirement.
    Happily using a 2009 vintage MacBookPro5,2 that can run OS X 10.10, but Mavericks is preferred – the appearance of Yosemite repelled me.
  • Loading…
  • Loading…
  • Loading…
Top