We're aware. It's not a bug though, and not caused by the move to the new server.
It's just a slightly overzealous Cloudflare managed challenge rule that's firing. It can be ignored for now.
Okay well your theme developer is wrong and the two software developers who have replied to you are correct. You may do with that information whatever you wish.
For the reasons we have mentioned, this is not a high priority fix. It is more likely to be fixed in a future XenForo release such as...
How so? It doesn't prevent anything from working. It's a deprecation notice. It doesn't break anything, it's merely a warning that some code may break in the future. And future is a long way off. It's stopping you from upgrading PHP to version 9.0, perhaps. But that's not something you need to...
Forum replies should be in English.
What you are reporting is unrelated to the PHP security advisories.
If you’d like to discuss this issue in more detail it would be best to provide more information at https://xenforo.com/contact/
Nope usually not. There are options to display it in headers etc. but it’s usually wise to remove those to make it harder for people to find servers running vulnerable versions.
But if you’re interested, we’re running PHP 8.3.36.
Yes. Most PHP versions up to 8.5 are compatible with XF 2.3.
You need to update it to PHP 8.3.36. This is not an issue you want to wait for. The PHP update is required or your forum is likely entirely vulnerable.
It is not a possibility. Just like it's not a possibility for PHP to release updates for versions below 8.2. There has to be a sensible cut off and the sensible cut off for XF 2.1 was years ago.