• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
[TH] Sub-Accounts

[TH] Sub-Accounts [Paid] 1.2.1f

No permission to buy ($10.00)

ThemeHouse

Well-known member
#1
Audentio Design submitted a new resource:

[TH] Sub-accounts - Allow your users to create sub-accounts. Great for character-based forums such as roleplaying sites.

This add-on adds the ability for your users to create new sub-accounts or request that existing accounts by added as sub-accounts of their account.

Newly created sub-accounts can be created without requiring an email address or password, meaning a user can create multiple accounts without having to have multiple email addresses. This is useful for sites where having multiple identities is expected, such as on roleplaying websites or other character-driven websites.

This add-on also...
Read more about this resource...
 

squirrly

Active member
#2
Purchased and attempting to upgrade from the Waindigo version, and the upgrade crashed. I can't get into the admin console:


Server Error
Mysqli prepare error: Not unique table/alias: 'subaccount_parent'

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 753
  5. Zend_Db_Adapter_Abstract->fetchRow() in XenForo/Model/User.php at line 446
  6. XenForo_Model_User->getUserById() in XenForo/Model/User.php at line 959
  7. XenForo_Model_User->getVisitingUserById() in Waindigo/ResCheckInOut/Extend/XenForo/Model/User.php at line 12
  8. Waindigo_ResCheckInOut_Extend_XenForo_Model_User->getVisitingUserById() in XenForo/Visitor.php at line 415
  9. XenForo_Visitor::setup() in XenForo/Session.php at line 419
  10. XenForo_Session::startAdminSession() in XenForo/ControllerAdmin/Abstract.php at line 48
  11. XenForo_ControllerAdmin_Abstract->_setupSession() in XenForo/Controller.php at line 306
  12. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 350
  13. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  14. XenForo_FrontController->run() in /home/thebaby/public_html/TBWTest/admin.php at line 13
 

Jake B.

Well-known member
#3
Purchased and attempting to upgrade from the Waindigo version, and the upgrade crashed. I can't get into the admin console:


Server Error
Mysqli prepare error: Not unique table/alias: 'subaccount_parent'

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 753
  5. Zend_Db_Adapter_Abstract->fetchRow() in XenForo/Model/User.php at line 446
  6. XenForo_Model_User->getUserById() in XenForo/Model/User.php at line 959
  7. XenForo_Model_User->getVisitingUserById() in Waindigo/ResCheckInOut/Extend/XenForo/Model/User.php at line 12
  8. Waindigo_ResCheckInOut_Extend_XenForo_Model_User->getVisitingUserById() in XenForo/Visitor.php at line 415
  9. XenForo_Visitor::setup() in XenForo/Session.php at line 419
  10. XenForo_Session::startAdminSession() in XenForo/ControllerAdmin/Abstract.php at line 48
  11. XenForo_ControllerAdmin_Abstract->_setupSession() in XenForo/Controller.php at line 306
  12. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 350
  13. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  14. XenForo_FrontController->run() in /home/thebaby/public_html/TBWTest/admin.php at line 13
Would you mind sending me a PM with admin and FTP details?

Jake
 
#4
Whenever I try to link an existing account to my primary, i am receiving an Unspecified Error. I had waindigos pst as user activated, and yes, i deactivated it but it is still giving me the error message. Please help! It was working fine initially.
 

Jake B.

Well-known member
#5
Whenever I try to link an existing account to my primary, i am receiving an Unspecified Error. I had waindigos pst as user activated, and yes, i deactivated it but it is still giving me the error message. Please help! It was working fine initially.
We'll look into this ASAP :)
 

Jake B.

Well-known member
#7
Whenever I try to link an existing account to my primary, i am receiving an Unspecified Error. I had waindigos pst as user activated, and yes, i deactivated it but it is still giving me the error message. Please help! It was working fine initially.
This is fixed in 1.1.1a :)
 

Gossamer

Active member
#10
I currently have Waindigo's version installed on a forum and am considering purchasing a second copy of this one and upgrading. What steps need to be taken to upgrade from Waindigo's to this version? Will my old subaccount data remain intact?

@ThemeHouse
 

Gossamer

Active member
#14
Happy to see that the usergroup inheritance settings seem to be working fine now.

However, there are still some features that don't appear to do anything:
  • Apply usergroup to all sub-accounts - this configuration doesn't seem to do anything. I've tried rebuilding the user caches, and have tried with both brand new and existing subaccounts
  • The "only show subaccount fields" option also does not appear to do anything
 

Gossamer

Active member
#15
Love the inclusion of the alerts! However, I noticed that while the alert notification shows up, if you're using the overlay view to switch accounts, you can't see which account has alerts


Would it be possible to add the alert # to the dropdown in that view?
 

silence

Well-known member
#16
Love the inclusion of the alerts! However, I noticed that while the alert notification shows up, if you're using the overlay view to switch accounts, you can't see which account has alerts


Would it be possible to add the alert # to the dropdown in that view?
Currently no since it just makes a single counter of all available alerts but I'll look into making the alerts separate :)
 

Gossamer

Active member
#17
Just to clarify, this is what it looks like in the dropdown version of the account switcher. I'm talking about the alert # that shows up next to each individual account. That only happens in the dropdown and not the overlay:


I wasn't sure if that's what you meant, so just double-checking.
 

silence

Well-known member
#18
Just to clarify, this is what it looks like in the dropdown version of the account switcher. I'm talking about the alert # that shows up next to each individual account. That only happens in the dropdown and not the overlay:


I wasn't sure if that's what you meant, so just double-checking.
Ah! Yeah I'll see what I can do!
 

Gossamer

Active member
#20
Hey @Gossamer could you describe to us the usergroup issue more, as I applied some type of fix but it didn't seem to be what you were looking for :(
Sure! There were actually two different usergroup issues, and the fix addressed one of them as far as I could tell.

The other one is related to this setting:

After setting that configuration, I rebuilt the user caches, but none of the subaccounts were assigned the Character Usergroup. I created a brand new subaccount as well, and it also was not given the Character usergroup.

However, the usergroup inheritance from the parent account is working fine now.