Redis Probleme

0815

Well-known member
Never had problems with umpteen sites. Now with the new project Redis only makes problems.

Have the settings in the Config already limited to a minimum and still only trouble.

Code:
$config['cache']['enabled'] = true;
$config['cache']['provider'] = 'Redis';
$config['cache']['config'] = [
    'host' => '127.0.0.1'
];


I also see with redis-cli monitor wonderfully how the data goes in/out.

But at the same time CSS makes problems 500 Error
screen_1658926972.png

Html is not parsed anymore
screen_1658926963.png




In addition, the error log of XF runs over there thousands of errors come in...
  • Template error that functions are unknown - but only as long as Redis is active
  • Method XY is not callable on the given object
  • Error rendering widget


does anyone have any ideas?

Had/have also already installed the XON Redis Add_on.
 

Attachments

  • screen_1658928050.png
    screen_1658928050.png
    51.6 KB · Views: 5

mcatze

Well-known member
If you use the Redis Cache by @Xon addon you should also use his config settings.

Code:
$config['cache']['enabled'] = true;
$config['cache']['provider'] = 'SV\RedisCache\Redis';
$config['cache']['config'] = [
    'server' => '127.0.0.1',
    'port' => 6379,
];
 

Abraham54

Well-known member
If you have no Redis configuration on your server, then you can try these settings:


Code:
$config['cache']['enabled'] = true;
$config['cache']['provider'] = 'SV\RedisCache\Redis';
$config['cache']['config']  = array(
        'server' => '/tmp/redis.sock',
        'compress_data' => 1,
        'compression_lib' => null,
        'serializer' => 'igbinary',
    );
 
Top