[OzzModz] Bulk User Create [Deleted]

Ozzy47

Well-known member
Ozzy47 submitted a new resource:

[OzzModz] Bulk User Create - Create users in bulk

Requirements:
XenForo 2.2.0+


Description:
Allows to create users in bulk using data lists from usernames, emails and passwords or with randomly generated


Features:

  • Bulk user adding with usernames or emails lists
  • Passwords also can be added in bulk as list or one for all users
  • Using random username generator if no username list entered (only English words supported)
  • Other fields will be used the same for all users

[ATTACH...

Read more about this resource...
 
Tried it... getting an error when attempting to add 5 users.

InvalidArgumentException: Unknown entity option: insert_username_change_visible in src/XF/Mvc/Entity/Entity.php at line 953
  1. XF\Mvc\Entity\Entity->setOption() in src/addons/OzzModz/BulkUserCreate/XF/Admin/Controller/User.php at line 258
  2. OzzModz\BulkUserCreate\XF\Admin\Controller\User->userBulkSaveProcess() in src/addons/OzzModz/BulkUserCreate/XF/Admin/Controller/User.php at line 170
  3. OzzModz\BulkUserCreate\XF\Admin\Controller\User->actionSaveBulk() in src/XF/Mvc/Dispatcher.php at line 350
  4. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 257
  5. XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 113
  6. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 55
  7. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2184
  8. XF\App->run() in src/XF.php at line 391
  9. XF::runApp() in admin.php at line 13
 

ExpressVB

Member
@Ozzy47
I am getting this error when trying to add a bulk user. Server is using nginx:

I can see from the access logs it's 404ing on the save process, 162.158.178.75 - - [08/Jun/2022:11:00:44 -0600] "POST /admin.php?users/save-bulk HTTP/1.1" 404 564 "https://website.com/admin.php?users/add-bulk" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.63 Safari/537.36" Which looks like an issue with the plugin itself (likely doesn't have a handler for /admin.php?users/save-bulk) since this works fine, /admin.php?users/add-bulk So will likely need to check with the plugin developer.
 

ExpressVB

Member
It loads fine. But when I hit the button, it says theres error I need to check in browser console which is the 404 error..
 

Painbaker

Well-known member
There should be a error like "This action is available via POST only. Please press the back button and try again".
Do you have this?


If so, then it's very strange. I don't know what is causing the problem.
Is your site connected to any traffic filtering system? Although this would affect other links.


Can you provide access to your admin panel in PM? With "Manage users" permission.
 
Top