1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

How to set “max_allowed_packet” in XAMPP Environment for MySQL

Discussion in 'Tips and Guides [Archive]' started by Robert F Schmitz, Oct 22, 2010.

  1. Robert F Schmitz

    Robert F Schmitz Well-Known Member

    When importing a database you may get a error due to the max_allowed_packet setting.

    To adjust this:

    Find xampp/mysql/bin/my.ini
    Set the following:

    max_allowed_packet = 512M
    max_allowed_packet = 512M
    Restart MySQL.

    The default is usually around 16M

    Hope that helps.
    51463, Nasr and Blandt like this.
  2. Nasr

    Nasr Well-Known Member

    I actually had to edit this today when I was trying to import a large database to my local server.
    Rob Fritz likes this.

Share This Page