1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP! I’ve screwed-up my netbook – need to copy the recovery partition.

Discussion in 'Off Topic' started by DoctorWatsOn, Aug 30, 2010.

  1. DoctorWatsOn

    DoctorWatsOn Well-Known Member

    Right, I’ve been a right idiot, I selected compress ‘c-drive’ in windows XP without realising it would compress the boot manager! [​IMG] Why the hell does it do that without warning? :mad:

    Anyway, I can’t for the life of me find the back-up usb drive I made 2 years ago, so I’ve managed to create a bootable usb of ubuntu linux and in Gparted I can see the recovery partition, which I want to copy to another usb drive.

    I am sat here looking at the recovery partition in one window and the other empty usb folder in another, but be buggered if I can work out how to copy it over. :confused:

    I’ve tried dragging it, no luck, I’ve right clicked it to copy it, but when I right click in the empty usb folder the option to paste is greyed-out.

    My techie mate has cleared off to the US for 2 weeks, I’ve got this charity beer & music festival I’ve organised for next weekend, but lots of stuff I’ve done on that is on the netbook, so I am in serious trouble here. :(

    Can anyone help?
  2. Kim

    Kim Well-Known Member

    Try control V to paste

    Not sure if it will help though.
  3. DoctorWatsOn

    DoctorWatsOn Well-Known Member

    I've tried that, no luck. :(
  4. Kim

    Kim Well-Known Member

    dang :(

    I can only empathise and wish you well then. [​IMG] Here's an ice cream to cheer you up.. [​IMG]
  5. Erik

    Erik Well-Known Member

    You can't copy a partition like you can a file. A partition is the whole file structure, the container in essence (with the files inside).

    I don't think "compressing the C drive" in Windows would corrupt the bootloader - the "C" drive in Windows is really only one partition on the drive, so compressing would only compress that partition, not anything else on the physical drive.

    Quick edit: the only way you would be able to copy the partition to the USB drive is if you copied it on the partition level using GParted. But you can't copy-paste it into a folder on the USB drive as if it was a file. :)

    If you can see the recovery partition, can you boot to it? What happens when you start the computer?

    If you want the quickest and most pain-free solution, I would boot a Ubuntu Live CD, then copy all your files off to a flash drive, then reformat and reinstall Windows. (If the files are compressed, though, you have to be careful - you need to be sure you can uncompress them).
  6. Jeremy P

    Jeremy P Well-Known Member

    Maybe it is read-only? Some flash drives have a small toggle switch for that.
  7. DoctorWatsOn

    DoctorWatsOn Well-Known Member

    No, can't boot from it - when I start the 'puter all I get is - BOOTMGR is compressed - Press Ctrl+Alt+Del to restart

    Oh, thanks *goes for a read*

    No, I can copy files OK, just not the partition.
  8. Erik

    Erik Well-Known Member

    Do you have the original installation media? If you do, you can use the recovery tools on the disc instead of trying to deal with the recovery partition.

    There are ways to fix this problem without re-installing, but they require the recovery tools as I'm sure you know. :)

    Edit: also, what's the make and model of the netbook? There should be a way to boot into the recovery partition on the drive even when the bootmanager is compressed/corrupted. :)
  9. DoctorWatsOn

    DoctorWatsOn Well-Known Member

    I've never used ubuntu linux and Gparted before, so I am totally lost, although that link looks promising, but it was published in 2006 and the interface I am looking at is totally different. :(

    Anyway, I *think* I've found my way around that now - it seems to now be copying, of course if this works, the next problem will be trying to get the netbook to boot from the recovery usb. [​IMG]

    I've spent over 6 hours on this so far today. [​IMG]
  10. DoctorWatsOn

    DoctorWatsOn Well-Known Member

    No original installation media, it comes pre-installed, with the advice you make your own recovery usb back-up, which I did, but can't find.

    It's a Advent Notebook, model 4489 < and I am not the only one to have had this problem - lol.
  11. Luke F

    Luke F Well-Known Member

    Boot into UBCD4Win/BartPE or something similar and uncompress the drive.

    Much less effort than having to reformat/recover everything :)
    DoctorWatsOn likes this.
  12. Erik

    Erik Well-Known Member

    I assume you've tried all the F2/F4/F8/F10/F11 tricks to get to the boot screen and try to boot into the recovery partition? :)
  13. DoctorWatsOn

    DoctorWatsOn Well-Known Member

    You've lost me on the 'BartPE' thing. :confused:

    But, yeah, uncompress the drive is what I am trying to get too.
  14. Erik

    Erik Well-Known Member

    This would work also, assuming you can get it to boot off the flash drive.
  15. Erik

    Erik Well-Known Member

    DoctorWatsOn likes this.
  16. Luke F

    Luke F Well-Known Member

  17. DoctorWatsOn

    DoctorWatsOn Well-Known Member

    What do you think I've been doing for the last 6 hours? :D

    I am laughing now I've got beyond swearing at the screen and almost throwing both the computers out the window!
  18. Erik

    Erik Well-Known Member

    Basically, you need to either a) access the original recovery partition, b) boot your copy of the recovery partition, or c) boot a 3rd-party Windows-based tool (like those linked above) that can decompress the hard drive. :)
    DoctorWatsOn likes this.
  19. DoctorWatsOn

    DoctorWatsOn Well-Known Member

    Well (a) seems impossible, (b) it doesn't seem to want to boot from the copy I've made. :(

    So, I guess I'll have to try (c) now. *cries*
  20. DoctorWatsOn

    DoctorWatsOn Well-Known Member

    Thanks, but it says you need the original Windows XP installation/setup CD, sadly none was supplied with the netbook. :(

    Ditto, it says you need an installation CD. :(

Share This Page