1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

First Post Edit Time Limit 1.0.0

Adds permissions to allow unliimited editing of first post

  1. Snog

    Snog Well-Known Member

    Mirovinger likes this.
  2. Mouth

    Mouth Well-Known Member

    Great idea, thanks!
    Any intention to expand it to allow forum node selection, so that it only applies on selected forums?
  3. Snog

    Snog Well-Known Member

    You can already do it in the forum node permissions.

    Mouth likes this.
  4. Mouth

    Mouth Well-Known Member

    Oh great, thanks! I thought it was a usergroup permission, not a node permissions.
  5. Snog

    Snog Well-Known Member

    Well it is by user group, but in the node permissions. ;)

    You can actually take it all the way down to an individual user in user permissions too.
    sunnytimeshere likes this.
  6. New Joe

    New Joe Active Member

    Nice, just found this, I can't believe I didn't know this one was here.
    Thanks @Snog
  7. loplo

    loplo Active Member

    Is this still compatible with the latest xf?
    I'm not able edit the first message, even if "Time limit on editing the first post in a thread:" is set to unlimited in the "Node Permission".
  8. Snog

    Snog Well-Known Member

    Yes it is.

    Make sure you have 'Edit post by self' allowed for your user group.
  9. loplo

    loplo Active Member

    Edit post by self is set to Allow, under "User Group Permissions: Registered"
    and under "Node Permissions: node name - Registered" the "Time limit on editing the first post in a thread:" is set to "Unlimited".
  10. Snog

    Snog Well-Known Member

    Check to be sure it's actually set to unlimited and not to inherit in the node.

    Also be sure the user doesn't belong to a user group that might be overriding those settings with 'revoke' or 'never'.

    You can use 'Analyze Permissions' to find out why it's not working for that user.
    Last edited: Jan 25, 2016
  11. loplo

    loplo Active Member

    Could be this one the cause: Time limit on editing/deleting own posts (minutes): 120

    Analyze permissions looks good, at least to me.

  12. Snog

    Snog Well-Known Member

    No, if the Time limit on editing/deleting own posts hasn't expired then the 'edit' link would be in the first post anyway. The add-on puts the edit link back in the post after that time limit has expired.

    Permissions look good and the edit link should be in the first post of a thread.

    If you have any other add-ons that might change the first post in a thread, try disabling them to see if they are interfering with this add-on.

    Also, check if it is working with the default XenForo style.
  13. loplo

    loplo Active Member

    Well, it's strange.
    I can't make it work. Could be something with the whole xf permission system? Is there a way to reset it? I can't imagine what else could be.
  14. Snog

    Snog Well-Known Member

    You must have some other add-on that is interfering with the system. You could try rebuilding your caches to see if that helps, but I don't know that it would.

    And there's nothing to reset. It's strictly a permission that is added to XenForo. If the permissions are set it should work, unless something else is interfering with it.

    OR it could be your browser is showing a cached page and not the newest version with the edit link enabled.

    I did a fresh install of 1.5.5(a) to be sure there isn't something different that might have affected the add-on and it works without a problem.

    1) I set the edit limit to 5 minutes and created a new thread without the add-on installed...

    2) After 5 minutes the edit link disappeared on the first post in the thread...

    3) Installed the add-on and set the first post edit time limit to 'unlimited' and the edit link is back on the first post in the thread...
    Last edited: Feb 1, 2016
    loplo likes this.
  15. loplo

    loplo Active Member

    I don't have any resource (AFAIK) that could interfere with this mod.
    Clearing and rebuilding caches, trying incognito mode in Chrome was already tested.

    The only thing it remains, it's the xf permission system, something disturbed it. I'd like to reset all the permissions to default, but I can't find anything related.
  16. Snog

    Snog Well-Known Member

    So far as I know, there is no way to set them back to default. That would be a question for the XenForo group. ;)

    If you want me to take a look at your system, I'm more than willing to do it. Just send me a temporary admin user name and password by PC. Just be sure the temporary user has full admin permissions.
  17. Snog

    Snog Well-Known Member

    For everyone's benefit....

    Analyze Permissions works with this add-on.
    Test Permissions does not work with this add-on.

    If you are going to test the system, create a test user on your site to test with. Do not use Test Permissions.
    Mouth and loplo like this.
  18. Mouth

    Mouth Well-Known Member

    Still works great with 1.5.13
    Snog likes this.

Share This Page