[CSCN] Debug Defender

[CSCN] Debug Defender 1.0.0

No permission to download

ShikiSuen

Well-known member
ShikiSuen submitted a new resource:

[CSCN] DebugDefender - Block access to the debug report page + allowing you to decide whether the debug footer shows up.

When using Development Mode on an active site, the debug information appears at the bottom of every page, compromising certain confidential intelligence. This plugin deals with this by:

1. Automatically replaces "_debug=1" to "_debug=0" to block the access to the debug report page. There's an option in the "Board active" setup in the AdminCP.
2. Hide debug footer to anyone by default, but there's an option to make it visible to admin users.
3. Reduced contents displayed in the debug footer...

Read more about this resource...
 

Hotfix

Active member
Thank you. I noticed the debug info on the footer just today and I was shocked. This add-on is a quick way to restore it back to what it looked like previously.
 

021

Well-known member
Thank you. I noticed the debug info on the footer just today and I was shocked. This add-on is a quick way to restore it back to what it looked like previously.
Isn't it an option to just disable debug in the config?
 

ShikiSuen

Well-known member
Sorry, I didn't understand you
Use this in lieu of my Debug Defender:
 

021

Well-known member
Use this in lieu of my Debug Defender:
What for? I have no need for this. I mean, in general, what is the essence of this add-on, when on a working project you can simply disable debug and it would be more correct to do it. It's just that @Hotfix wrote that debug information is displayed in his footer and he may not know how to turn it off. It would be more correct not to use debug on a working project than to put an add-on that blocks access to it in such a strange way, this is called a crutch
 

ShikiSuen

Well-known member
What for? I have no need for this. I mean, in general, what is the essence of this add-on, when on a working project you can simply disable debug and it would be more correct to do it. It's just that @Hotfix wrote that debug information is displayed in his footer and he may not know how to turn it off. It would be more correct not to use debug on a working project than to put an add-on that blocks access to it in such a strange way, this is called a crutch
Sometimes you have to hot-fix some template / addon issues in the AdminCP on a running site without being noticed by those frontpage visitors.
That's why I made this plugin.

P.S.: Who the bloody hell do you think you are? If you want to taunt, taunt first instead of wasting our time here.
 

Kirby

Well-known member
Sometimes you have to hot-fix some template / addon issues in the AdminCP on a running site without being noticed by the frontpage visitors.
Debug mode should never be enabled (for normal users) on production systems.

If it absolutely must be enabled, do so only for the required IP address - this can easily be done via config.php without the need for an Add-on.
 

Kirby

Well-known member
Easy for Devs, not for Admins to debug a template, so they need a add-on...
Btw. Howto enable debugmode for only one IP?
It's really just a configuration ... that a normal admin never touches (except if guided so) and has been explained in the FAQ for ages ...

PHP:
if (isset($_SERVER['REMOTE_ADDR']) && $_SERVER['REMOTE_ADDR'] === 'a.b.c.d')
{
    $config['debug'] = true;
}
 
Last edited:

021

Well-known member
P.S.: Who the bloody hell do you think you are? If you want to taunt, taunt first instead of wasting our time here.
Nobody taunted you, dude. I didn't even reach out to you in the first place. You just released an add-on that makes people misunderstand debug, and which, in its essence, is a crutch for those who do not understand how it works. I just drew the person's attention to the fact that it would be more correct to just not enable debug on a working project, and @Kirby sent a variant, which is also more logical, if you really need to enable debug on a working project. But I didn't say anything in your direction. I see that you are only at the beginning of your development way and you simply don’t know much about XenForo, so you made an addition that is a crutch (alas, but this is so, and this does not characterize you in any way, this is just a lack of knowledge). Criticism from the outside is an integral part of the developer's development, the main thing is not to take it as ridicule, but take it as an excuse to become better.



Sorry that I only came to Xenforo with XF 2.x in 2018 and that I haven't even got all the necessary information about the 2.x yet. You can't expect me to know everything about XF 1.x as well.
A bit strange argument, because I just have to google "xenforo enable debug for ip", and I will get the answer to my question in the first link ;)
 

ShikiSuen

Well-known member
Debug mode should never be enabled (for normal users) on production systems.

If it absolutely must be enabled, do so only for the required IP address - this can easily be done via config.php without the need for an Add-on.
ISPs in Mainland China won't offer fixed IP for their individual customers, hence the fact that it is unable to set up a static IP whitelist.
Political correctness won't help anyone. The fact is that the siteowner I work with has his reason to keep his site running.
I put the addon here for easier maintenance.

P.S.: I chose to report 021's replies due to his harbour ill intent.
 
  • Haha
Reactions: 021
Top