1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Change Analyzer For Enhanced Search

Make XenForo's Enhanced Search *not* treat punctuation as part of a word.

  1. digitalpoint

    digitalpoint Well-Known Member

    digitalpoint submitted a new resource:

    Change Analyzer For Enhanced Search (version 1.0) - Make XenForo's Enhanced Search *not* treat punctuation as part of a word.

    Read more about this resource...
    Walter, p4guru and CyclingTribe like this.
  2. DomainArchitect.com

    DomainArchitect.com Active Member

    Can you give another example of how this would make search more effective for the average user. This resource intrigues me!
  3. digitalpoint

    digitalpoint Well-Known Member

    DBA likes this.
  4. CyclingTribe

    CyclingTribe Well-Known Member

    Rebuilding CycleChat search index now - thanks. (y)
  5. snoopy5

    snoopy5 Well-Known Member


    on my Server, the mysql search length minimum is set to "4" and I can not change this. Would this addon help me to find postings if I search i.e. for "28" or "28-75" or "50/1.4"?
  6. digitalpoint

    digitalpoint Well-Known Member

    If you are using XenForo's Elastic Search systen, yeah.
  7. graham_w

    graham_w Active Member

    The Enhanced search does not use mysql so is not restricted by that setting at all.
  8. RoldanLT

    RoldanLT Well-Known Member

    What I did is:
    1. Add this to your elasticsearch.yml file:
    index.analysis.analyzer.default.type: custom
    index.analysis.analyzer.default.tokenizer: pattern
    index.analysis.analyzer.default.filter: ["standard", "lowercase", "stop", "snowball"]

    2. rcelasticsearch restart

    3. Delete Index here: /admin.php?elasticsearch/

    4. Done :)

    Hope it's correct.

Share This Page