XF 2.2 Can't Create User Groups Due To Error?

BigPete7978

Active member
So I am trying to setup user group promotions based upon post criteria, but when trying to create a User Group I am getting this error when I hit submit in the ACP. Any ideas?

Code:
XF\Db\Exception: MySQL query error [1364]: Field 'avatar_frame_enable' doesn't have a default value in src/XF/Db/AbstractStatement.php at line 228
XF\Db\AbstractStatement->getException() in src/XF/Db/Mysqli/Statement.php at line 196
XF\Db\Mysqli\Statement->getException() in src/XF/Db/Mysqli/Statement.php at line 77
XF\Db\Mysqli\Statement->execute() in src/XF/Db/AbstractAdapter.php at line 94
XF\Db\AbstractAdapter->query() in src/XF/Db/AbstractAdapter.php at line 218
XF\Db\AbstractAdapter->insert() in src/XF/Mvc/Entity/Entity.php at line 1510
XF\Mvc\Entity\Entity->_saveToSource() in src/XF/Mvc/Entity/Entity.php at line 1242
XF\Mvc\Entity\Entity->save() in src/XF/Mvc/FormAction.php at line 69
XF\Mvc\FormAction->XF\Mvc\{closure}() in src/XF/Mvc/FormAction.php at line 187
XF\Mvc\FormAction->run() in src/XF/Admin/Controller/UserGroup.php at line 120
XF\Admin\Controller\UserGroup->actionSave() in src/XF/Mvc/Dispatcher.php at line 350
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 257
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 113
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 55
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2300
XF\App->run() in src/XF.php at line 488
XF::runApp() in admin.php at line 13
 

BigPete7978

Active member
I assume this is from an add-on. Most likely an add-on that deals with avatars.
The only avatar add-ons I currently have installed are the Mentions Mini Avatar and @Ozzy47's Alpha Avatar. I tried out the XTR Avatar Frame add-on a long time ago, but it has been deleted and uninstalled for quite some time.

I have tried disabling both add-ons that I have, even disabling ALL add-ons on my site and creating a user group. I am still getting the error.
 

KSA

Well-known member
What would be the easies way to accomplish this? The files have already been deleted via FTP for quite some time now.

I will have to look in the database first to help you out but If you have access to the server e.g. Cpanel, you can use phpmyadmin to search for the avatar_frame_enable column. Run a simple query to drop it, it should look like this:

SQL:
ALTER TABLE table_name DROP COLUMN avatar_frame_enable;
Replace table_name with the relevant table where the column is associated with.

Don't forget to backup first. If you have no idea what I am talking about then perhaps you should consult the author of the add-on to help you out.
 

Brogan

XenForo moderator
Staff member
Uninstall the add-on, drop the table from the database manually if the uninstall routine doesn't do it automatically.

Contact the author of the add-on if you need assistance with doing that.
 

KSA

Well-known member
Uninstall the add-on, drop the table from the database manually if the uninstall routine doesn't do it automatically.

Contact the author of the add-on if you need assistance with doing that.

That's exactly what I said. Some addons are built very badly where the uninstall process doesn't remove the tables the addon created. I myself have come across this issue before and I had to drop the table manually.
 

DreamNetworks

Active member
It''s this addon: https://xenforo.com/community/resources/xtr-user-group-avatar-frame.8237/

Last update was January 24, 2021. Which version of XF are you using?

It seems like a database related problem, that can be solved. But it will not be an original solve from the addon developer itself.

As I read the comments, I probably have the idea with uninstalling the xtr user group avatar frame addon, some of the tables have been left in the database. If you are not using this addon and it''s fully deleted from your XF, then please find "avatar_frame_enable" in your database and remove that row :) (Make sure you always make a backup first!)
 
Top