[BS] High privacy

[BS] High privacy 1.2.1g

No permission to download

Niro

Active member
Hi,

I am getting the following error:

Code:
ErrorException: [E_WARNING] Declaration of TickTackk\ConversationLastReadTime\XF\Pub\Controller\Conversation::assertViewableUserConversation($conversationId, array $extraWith = Array) should be compatible with BS\HighPrivacy\XF\Pub\Controller\Conversation::assertViewableUserConversation($conversationId, array $extraWith = Array, $checkSecure = true) in src/addons/TickTackk/ConversationLastReadTime/XF/Pub/Controller/Conversation.php at line 60

Any advice to fix it? thanks!
 
  • Like
Reactions: 021

Iggy

Well-known member
hello @021,
ive just noticed on xen2.2.3 a minor issue..
this little guy not showing up anymore :(
template code changed somewhere recent on

structured_list.less​

1571315189316-png.212149
 
Last edited:

Iggy

Well-known member
@021 hello, sill hoping for the last bugix but i just found another...

cannot edit messages using encryption....lie any way...not even moderator\admin.....throws error like this

  • TypeError: String expected for argument 1. Object given instead.
  • src/addons/BS/HighPrivacy/vendor/defuse/php-encryption/src/Crypto.php:61
  • Generated by:admin
  • Aug 27, 2021 at 5:45 PM

Stack trace​

#0 src/addons/BS/HighPrivacy/Listener.php(84): Defuse\Crypto\Crypto::encryptWithPassword(Object(XF\Phrase), '*****')
#1 [internal function]: BS\HighPrivacy\Listener::entityPreSaveConversationMessage(Object(SV\Threadmarks\XF\Entity\ConversationMessage))
#2 src/XF/Extension.php(50): call_user_func_array(Array, Array)
#3 src/XF.php(930): XF\Extension->fire('entity_pre_save', Array, 'XF\\Entity\\Conve...')
#4 src/XF/Mvc/Entity/Entity.php(1362): XF::fire('entity_pre_save', Array, 'XF\\Entity\\Conve...')
#5 src/XF/Service/Conversation/MessageEditor.php(93): XF\Mvc\Entity\Entity->preSave()
#6 src/XF/Service/ValidateAndSavableTrait.php(17): XF\Service\Conversation\MessageEditor->_validate()
#7 src/XF/Pub/Controller/Conversation.php(966): XF\Service\Conversation\MessageEditor->validate(NULL)
#8 src/addons/Snog/ForceSecure/XF/Pub/Controller/Conversation.php(41): XF\Pub\Controller\Conversation->actionMessagesEdit(Object(XF\Mvc\ParameterBag))
#9 src/XF/Mvc/Dispatcher.php(350): Snog\ForceSecure\XF\Pub\Controller\Conversation->actionMessagesEdit(Object(XF\Mvc\ParameterBag))
#10 src/XF/Mvc/Dispatcher.php(257): XF\Mvc\Dispatcher->dispatchClass('XF:Conversation', 'Messagesedit', Object(XF\Mvc\RouteMatch), Object(SV\MultiPrefix\XF\Pub\Controller\Conversation), NULL)
#11 src/XF/Mvc/Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(SV\MultiPrefix\XF\Pub\Controller\Conversation), NULL)
#12 src/XF/Mvc/Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#13 src/XF/App.php(2326): XF\Mvc\Dispatcher->run()
#14 src/XF.php(488): XF\App->run()
#15 index.php(20): XF::runApp('XF\\Pub\\App')
#16 {main}


regards
 
  • Like
Reactions: 021

Mbx

Member
@021 hello, sill hoping for the last bugix but i just found another...

cannot edit messages using encryption....lie any way...not even moderator\admin.....throws error like this

  • TypeError: String expected for argument 1. Object given instead.
  • src/addons/BS/HighPrivacy/vendor/defuse/php-encryption/src/Crypto.php:61
  • Generated by:admin
  • Aug 27, 2021 at 5:45 PM

Stack trace​

#0 src/addons/BS/HighPrivacy/Listener.php(84): Defuse\Crypto\Crypto::encryptWithPassword(Object(XF\Phrase), '*****')
#1 [internal function]: BS\HighPrivacy\Listener::entityPreSaveConversationMessage(Object(SV\Threadmarks\XF\Entity\ConversationMessage))
#2 src/XF/Extension.php(50): call_user_func_array(Array, Array)
#3 src/XF.php(930): XF\Extension->fire('entity_pre_save', Array, 'XF\\Entity\\Conve...')
#4 src/XF/Mvc/Entity/Entity.php(1362): XF::fire('entity_pre_save', Array, 'XF\\Entity\\Conve...')
#5 src/XF/Service/Conversation/MessageEditor.php(93): XF\Mvc\Entity\Entity->preSave()
#6 src/XF/Service/ValidateAndSavableTrait.php(17): XF\Service\Conversation\MessageEditor->_validate()
#7 src/XF/Pub/Controller/Conversation.php(966): XF\Service\Conversation\MessageEditor->validate(NULL)
#8 src/addons/Snog/ForceSecure/XF/Pub/Controller/Conversation.php(41): XF\Pub\Controller\Conversation->actionMessagesEdit(Object(XF\Mvc\ParameterBag))
#9 src/XF/Mvc/Dispatcher.php(350): Snog\ForceSecure\XF\Pub\Controller\Conversation->actionMessagesEdit(Object(XF\Mvc\ParameterBag))
#10 src/XF/Mvc/Dispatcher.php(257): XF\Mvc\Dispatcher->dispatchClass('XF:Conversation', 'Messagesedit', Object(XF\Mvc\RouteMatch), Object(SV\MultiPrefix\XF\Pub\Controller\Conversation), NULL)
#11 src/XF/Mvc/Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(SV\MultiPrefix\XF\Pub\Controller\Conversation), NULL)
#12 src/XF/Mvc/Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#13 src/XF/App.php(2326): XF\Mvc\Dispatcher->run()
#14 src/XF.php(488): XF\App->run()
#15 index.php(20): XF::runApp('XF\\Pub\\App')
#16 {main}


regards
Excatly,

TypeError: String expected for argument 1. Object given instead. in src/addons/BS/HighPrivacy/vendor/defuse/php-encryption/src/Crypto.php at line 61
 

deslocotoco

Well-known member
Dear @021,

Can i please make a suggestion?
Our laws require us to log the IP address from users, so, i cannot disable this logging.

Is a great idea for countries who respect privacy, but, to comply with my law, can you add the function to give the users the option to encrypt their own IPs? Or maybe a Administrative power to do so for every user?

And to decrypt, we should have some kind of key to see the real IP.

Can you add this?

I can make some kind of donation to help fund this new feature.

BTW, as i can see, some users are reporting some errors/bugs. Would be fixed?
 

deslocotoco

Well-known member
Not been a pain in the ass, sorry, but just asking, any news on the next update?

My users are literally claiming for this, so, just to give them some feedback.

Also, like always, great job 021! 😬
 
Top