Using DigitalOcean Spaces or Amazon S3 for file storage in XF 2.1+

Using DigitalOcean Spaces or Amazon S3 for file storage in XF 2.1+

No permission to download
This update is a very minor maintenance release.

As well as including the latest version of the Amazon AWS SDK (3.231.7) this is now a much smaller subset of the behemoth that is the full SDK that only includes the necessary files to access Amazon S3 services.

There is no real need to install this version if everything is working as expected.

Note​

Simply upgrading the add-on will leave remnants of the full-size Amazon AWS SDK on your file system. If you wish to avoid this, you will first of all need to take the following steps:
  1. Close your forum temporarily
  2. Comment out the src/config.php changes to make Amazon S3 storage work (place // at the start of each line)
  3. Uninstall the existing version of the add-on
  4. If you are running a recent version of XF 2.2 you can use the "Delete files" option in the add-on list to remove the files. Otherwise you can delete the add-on files under src/addons/XFAws
  5. Install the latest version of the add-on
  6. Uncomment the aforementioned lines in src/config.php
  7. Re-open your forum
The last update to this add-on updated the Amazon AWS SDK to version 3.204.2 but it implied this may not be required due to it only adding support for PHP 8.1.

We are further updating the AWS library today to version 3.209.16.

While there are still no significant changes in the behaviour of this add-on itself we do recommend updating to ensure you're using a more recent version of the library.
  • Like
Reactions: e-Dewan and Jim Boy
There are no changes here apart from added support for PHP 8.1.

It's up to you whether you update or not but be aware that if you ever update to PHP 8.1 you will eventually need this version.

This version drops support for XF 2.0. This will only work with XF 2.1 or above.
This update now includes two different add-ons. One is compatible with XF 2.0 and the other is compatible with XF 2.1.

The instructions have also been changed to avoid errors when accessing the install system in XF 2.0.

This change also introduces a slightly changed approach to avoid the repeated code when setting up the AWS SDK client.

The XF 2.1 version of the add-on also does not require the autoloader stuff to be applied as the add-on does that automatically. However, note that until XF 2.1 Beta 3 the install system may still not work. You will need to comment out all of the S3 related code before accessing the install system.
Back
Top Bottom