Monolog Logging Service

Monolog Logging Service 4.0.0

No permission to download
v4 implememts Monolog v2

Important to note is that the default date format in logs has changed for v2 - but for backwards compatibility I have reset the date format to that used by v1.

There is no new functionality in this version.

If you need Monolog v1 support - stay on the 3.x version of this addon - I will maintain that version for critical bugfixes.
XenForo v2.2 moved to Swiftmailer v6 - this addon release maintains compatibility across both XF 2.1 and XF 2.2

Addon now works on both XF 2.1 and XF 2.2
  • Like
Reactions: yin9
  • updates for XF 2.1
I am changing the structure of the addon_id I use for my addons - so this version is a re-release of the functionality currently available in v2.1.1, but with a new addon_id.

Note that you cannot directly upgrade from v2.1.1 - there are additional manual steps required - please see upgrade instructions below.

If you don't yet have v2.x installed, just install v3.x as you would normally do for any addon. If upgrading from v2.x of the addon, follow the instructions below.

Upgrade instructions from v2.x of the addon (read this in full before starting!):

A) Easy upgrade from v2.x - lose option configuration

If you don't mind reconfiguring the addon options - you may simply uninstall the existing addon (and remove the files from the file system!) and then install this new v3.x version

B) Full upgrade from v2.x - retain cached data and option configuration

To retain all cached data and configuration settings, carefully follow these steps (caution - doing these in the wrong order or missing a step can lead to data loss!):
  1. back up your forums (both database and file system) before attempting to upgrade - you could lose data if you get the steps wrong!
  2. it is highly recommended that you close your forums before starting the upgrade process
  3. In your favourite database browser tool, locate the xf_addon table for your forum installation and then find the row with the addon_id = Monolog
  4. Change the is_legacy field for this row and set the value to 1. This will mark the addon as "legacy" in the admin UI and disable the addon
  5. Extract the new v3.0.x addon to the file system. It won't over-write the existing addon installation because of the change in addon_id
  6. Refresh the addon list in the UI - the system should offer to upgrade the addon instead of installing it, having detected that the old addon is the "legacy" version
  7. Proceed with the upgrade - all data and option settings will be retained, the old addon will be uninstalled and show up in the admin UI as "Installable". Do NOT re-install the old addon!
  8. Remove the old addon files from the file system completely - these can be found in <forum_root>/src/addons/Monolog
  9. Test that the new version of the addon works - look for the test suite in the Tools section of the admin UI
  • was using the wrong subcontainer name
  • move subcontainer out of XF namespace
  • bump version_id to 2004 to avoid conflicts with XF 1.x compatible releases
  • added helper class for logging
  • added support for emailing log messages
  • added configuration options
  • simplified logger test
Top