1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"You cannot proceed unless all XenForo database tables are removed"

Discussion in 'Installation, Upgrade, and Import Support' started by CBI Web, Oct 9, 2010.

  1. CBI Web

    CBI Web Well-Known Member

    Installing on my local dev machine, and got this error :(


    You cannot proceed unless all XenForo database tables are removed.

  2. Shadab

    Shadab Well-Known Member

  3. CBI Web

    CBI Web Well-Known Member

    Nope, all components were downloaded, installed and configured manually. Apache, MySQL, PHP, etc. My environment passes the requirements test script; everything's a go, except for the above error.
  4. Peggy

    Peggy Well-Known Member

    If you're installing this over another xf installation, then go ahead and remove them.
  5. CBI Web

    CBI Web Well-Known Member

    This is my first install since getting my license earlier today. Also forgot to mention my software versions, in case it makes a difference:

    PHP 5.2.14
    MySQL 5.0.51a
    Apache 2.2.16
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have MySQLi installed?
    Have you downloaded the latest test script, Mike updated it a few days ago.
  7. CBI Web

    CBI Web Well-Known Member

    If I didn't have MySQLi, or hadn't tested with the latest test script, I would not have gotten as far as the error in question. ;)
  8. Brogan

    Brogan XenForo Moderator Staff Member

    So are there any tables in the DB or is it empty?
  9. CBI Web

    CBI Web Well-Known Member

    Strangely, there are tables in the db at this point. In fact, since opening this thread I re-downloaded the beta and started from scratch; including deleting the db and all files from the first install. A brand new fresh install has given me the same error, and 119 tables in the db.

    How do I "let it" remove the tables? There is only the error, with no options to continue or not.
  10. Mike

    Mike XenForo Developer Staff Member

    It's fixed in beta 2. As a workaround, you can ensure that PHP interfaces with Apache via (Fast)CGI instead of mod_php.
  11. CBI Web

    CBI Web Well-Known Member

    hoo boy.... I'll have to google that, lol. Thanks. :) ...um, beta 2 is tomorrow, right? :rolleyes:
  12. Peggy

    Peggy Well-Known Member

    ummmmm... nope.
  13. vijayninel

    vijayninel Active Member

    I also get the same error :(

    You cannot proceed unless all XenForo database tables are removed.
  14. CBI Web

    CBI Web Well-Known Member

    Just dropping in to say I was able to install XF on my remote server with no problems at all. So there must be something in my local config that's stopping the show, but I have no idea what it might be. I'll wait for beta 2 to see how it goes locally, and enjoy playing with it on the remote server in the meantime. :D (so far it's a total joy and breath of fresh air!)
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Great news.

    Have fun :D
  16. vijayninel

    vijayninel Active Member

    Sob .. sob .. no great news for me ... I have vb3, smf, joomla etc ... working on my localhost .. only xenforo refuses to install...
  17. vijayninel

    vijayninel Active Member

    Ahahahaha .. great news ! I finally managed to install it on another system. I did exacty the same thing, but it installed on this system and not the other one .. I cant figure out why..

    Anyway the admin cp is so nice and looks sophisticated .... and although I'm not a coder I can tell this is nothing like vBulletin at all. The last of my doubts regarding IB's claims that xenforo is stolen vBulletin are now removed. :)
  18. Justine

    Justine New Member

    I have the same error You cannot proceed unless all XenForo database tables are removed.

    I installed today the newest 1.1.2 version after several attempts of upgrading from 1.1.1 to 1.1.2 which failed (lucky me forum was empty)
    I removed old database and create new with new user. The database before installing was empty for sure, I even create a new folder for the forum, but I still get this error.
    The error whike I tried to upgrade was

    An error occurred or the request was stopped.

    then this

    Server Error

    Mysqli statement execute error : Lock wait timeout exceeded; try restarting transaction
    Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 661
    Zend_Db_Adapter_Abstract->delete() in XenForo/Model/AdminNavigation.php at line 597
    XenForo_Model_AdminNavigation->deleteAdminNavigationForAddOn() in XenForo/Model/AdminNavigation.php at line 622
    XenForo_Model_AdminNavigation->importAdminNavigationAddOnXml() in XenForo/Model/AdminNavigation.php at line 608
    XenForo_Model_AdminNavigation->importAdminNavigationDevelopmentXml() in XenForo/CacheRebuilder/ImportMasterData.php at line 35
    XenForo_CacheRebuilder_ImportMasterData->rebuild() in XenForo/ControllerHelper/CacheRebuild.php at line 26
    XenForo_ControllerHelper_CacheRebuild->rebuildCache() in XenForo/Install/Controller/Upgrade.php at line 232
    XenForo_Install_Controller_Upgrade->actionRebuild() in XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /var/www/**/data/www/forum.**.ru/install/index.php at line 18

    Now I do not know what to do at all..
    I mean how to install this 1.1.2 version (not upgrading) if i receive the error. I looked to my ispmgr to this database which I created it is still empty and in config.php there are correct details of this database..
  19. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is a MySQL limit.

    If you have root access to the server then you can edit the my.cnf file (usually at /etc/my.cnf) to increase the value of innodb_lock_wait_timeout. Increasing that limit should avoid this error. If you don't have root access then you need to ask your host or server person to do this.
  20. Justine

    Justine New Member

Share This Page