XenWord Pro

XenWord Pro [Paid] 2017

No permission to buy ($49.99)

LPH

Well-known member
I updated the Posts.php file with the new API. This works fine with WordPress 4.8.

There was a glitch at one point of duplicate comments; however, I wasn't able to trace down what was happening. The code, of course, needs lots of testing and I'm willing to put it out there for beta testing - and not live production. I'm very uneasy about not figuring out why there was duplication at one point. I can't recreate it but don't want someone to try this on their site and run into issues.

To get the beta, simply open a ticket and Gracie should be able to attach it. I want to keep this limited. I'll keep tinkering because there is another location of my using get_comments. I'm also debating if there is a better way to narrow down the query.

This is the basic query.

PHP:
// Get WordPress Comments
$args = array(
   'meta_key' => 'thread_id',
   'meta_value' => $threadId,
);

$comments_query = new WP_Comment_Query;
$comments = $comments_query->query( $args );
 

Gregory Lynn

Well-known member
While I am waiting for help on the main forums I was wondering if anyone knows how to fix my graphic problem in the Login widget and the Community Statistics widget. Here is a picture of whats going on and I am using the graphene theme for wordpress.
 

Optic

Well-known member
I've changed the usernames of some members on the XF side.

Now I've noticed the Username and Last Name on the WP side does not update.

The Nickname on the WP side does however update, which allows me to adjust "Display name publicly as..." to the new nickname.

Will this cause any issues later down the track?
 
Anyone happen to be using this that also uses RSS feeds to auto post? I'm trying to get that to work and the posts are created, my XenWord settings are correct but no thread is generated. I have to manually go back into the posts and click Update to have the thread created.

If I manually create a Wordpress post and hit publish, it does create a thread.
 
New Feature: Enable or disable a link to the discussion forum below the WordPress post content.
...
Like this feature only one problem it's not picking up the themes button color combination.

Capture.PNG

Notice the 'discuss in our community' button is hard to read. I can't figure out how to change the color combination for normal and hover state. Really only way to read it now is to mouse over hover as it lights up with a white back ground and the text remains black.

Where can I change the colors for this button?
 
Would I be able to connect statistics (latest threads, total amount of users, total amount of threads etc) from 2 standalone XF installations to Wordpress via this addon? Each standalone XF installation is located on subdomain
 

Goodfella

Well-known member
Like this feature only one problem it's not picking up the themes button color combination.

View attachment 154517

Notice the 'discuss in our community' button is hard to read. I can't figure out how to change the color combination for normal and hover state. Really only way to read it now is to mouse over hover as it lights up with a white back ground and the text remains black.

Where can I change the colors for this button?
Take a look in the public css file (/public/css/xenword-public.css).
 
I just brought this - and was wondering if there was someone cluey enough to install it for us?
We have a WordPress website with our users on it - and have only purchased and added xenforo today. We would however, like to have where our members (current users on WordPress) could login and have access to our new xenforo website as well.

Any assistance is greatly appreciated please contact if you can install.
 

Goodfella

Well-known member
I just brought this - and was wondering if there was someone cluey enough to install it for us?
We have a WordPress website with our users on it - and have only purchased and added xenforo today. We would however, like to have where our members (current users on WordPress) could login and have access to our new xenforo website as well.

Any assistance is greatly appreciated please contact if you can install.
Have you tried following the Instruction? https://www.tuxreports.com/community/xenword/xenword-installation.3/

If you need a hand feel free to contact me.
 
If I use the events manager plugin to create events, will this plugin allow users to login/register for the events with their xenforo account? It seems like it will but I want to confirm before purchasing. Thanks!
 
Hello, love this idea and I think I'll buy it since I'd want to create an e-commerce with WooCommerce on my main site and let all the XF users access this for orders. Is what the addon is intended for isnt'it? Basically I'd just need to sync the users between XF and WP stating that I've no users but one admin on my ZP installation so the bridge is needed only to let the forum users use Woocommerce...

Do you plan to release a version also for the new 2.0 version of Xenforo?
 

jauburn

Well-known member
This is the stumbling block for this add-on for anyone with an established Xenforo community who would like to align WordPress permissions. Aligning the IDs manually, which appears to be the only option, would take me days, at best--more like weeks. And I would have to do this knowing full well that most of the xenforo members would never post on the WP side, making all of my hard work pointless.

So if you could come up with a way to automate this process, I would buy (again) this add-on. Until then, it's a no-go. I think the major work involved in aligning IDs before this add-on can be used by existing, established forums should be highlighted right up front, in bold, red letters, repeatedly. It wasn't until after I purchased the thing did I see this very crucial bit of information, which made the whole thing a nonstarter for me.
 

Kirby

Well-known member
@LPH
I tried to register an account @ tuxreports.com in order to purachse a license for XenWord Pro.

Unfortunately I didn't get an activation email and trying to resend the actvation doesn't work either, I just get an error that the CAPTCHA was not completed.

As you explicity forbit to contact you via E-Mail and you seem to have disabled the standard contact form too I'm trying to get some support here as I can't post on your forums (yet).
 
Top