1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Xenmods] Same Thread Feed [Paid] [Deleted]

Discussion in 'Add-on Releases' started by Daniel Hood, Sep 16, 2013.

  1. Daniel Hood

    Daniel Hood Well-Known Member

    Daniel Hood submitted a new resource:

    [XenMods] SameThreadFeed - Confine rss feeds to one thread (optional)

    Read more about this resource...
     
  2. Matthew Hawley

    Matthew Hawley Well-Known Member

    I got banned from sports discussion some reason......Sheldon keeps banning me from his sites.

    Another site?
     
  3. oman

    oman Well-Known Member

    A bit off topic for this specific thread, but it might be better to PM @Sheldon, as he may be able to explain a bit further.
     
  4. Matthew Hawley

    Matthew Hawley Well-Known Member

    The demo is at sportsdiscussion, so I cant see the demo
     
  5. Sheldon

    Sheldon Well-Known Member

  6. Daniel Hood

    Daniel Hood Well-Known Member

    It's just come to my attention that deleting the thread will cause this not to work, posts will be inserted into a deleted thread and you will get some "NOTICE: " errors in your error log (the post datawriter tries updating the node of the thread but the thread doesn't exist).
     
  7. Kevin

    Kevin Well-Known Member

    Daniel, any thoughts on this error during installation?

     
  8. Daniel Hood

    Daniel Hood Well-Known Member

    disable debug mode, I'll fix it for the next release though.
     
  9. Kevin

    Kevin Well-Known Member

    Disabling debug mode took care of it, thanks. (y)
     
  10. Daniel Hood

    Daniel Hood Well-Known Member

    No problem, enjoy :)
     
  11. DRE

    DRE Well-Known Member

    Instead of threads, how about a different route? For instance, forums have threads, blogs have entries and gallery have albums. I propose a new route so that instead of threads, the 'subforum' would be called news and the 'threads' would be called feeds. I've asked for this before http://xenforo.com/community/threads/rss-feeds-section-with-own-thread-ids.36996/ because I noticed that when you use RSS and you end up getting a lot of useless threads, it feels like a waste of the thread ids.
     
  12. Daniel Hood

    Daniel Hood Well-Known Member

    With this you only "waste" one id. You could use a route filter to customize the path to that one thread. I can do the other thing but that's an entirely different type of add on lol
     
  13. DRE

    DRE Well-Known Member

    I'm not sure what you mean? I was referring to the feeds being it's own content type instead of threads/posts. But they would sorta look like threads/posts.
     
  14. Daniel Hood

    Daniel Hood Well-Known Member

    Yeah I know what you're suggesting That's just a little more complex than this.

    What I was referring to with route filters is, I think you can point /news/{title}.{id}/ to /threads/{title}.{id}/. I know that was only half the concept though and you want it to actually be it's own route though.
     
  15. otaku

    otaku Member

    Got a small conflict with this mod: [vFcoders] Ajax First (or Last) Post Collapsable 1.0
    http://xenforo.com/community/threads/vfcoders-ajax-first-or-last-post-collapsable.47843/
    Code:
    Argument 1 passed to XenForo_Model_Post::preparePost() must be an array, boolean given, called in /home/beta/public_html/library/vFcodersAFPCH/ControllerPublic/Index.php on line 57 and defined
    XenForo_Application::handlePhpError() in XenForo/Model/Post.php at line 997
    XenForo_Model_Post->preparePost() in vFcodersAFPCH/ControllerPublic/Index.php at line 57
    vFcodersAFPCH_ControllerPublic_Index->actionAjaxFirstPost() in XenForo/FrontController.php at line 347
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/fikushon/public_html/index.php at line 13
    Is this fixable or do I need to uninstall [vFcoders] Ajax First (or Last) Post Collapsable 1.0? I'm getting this error when I click on the plus button. It works with other threads but not with "same feed threads"
     
    Last edited: Mar 9, 2014
  16. Daniel Hood

    Daniel Hood Well-Known Member

    I'm not really sure why my addon would conflict with that one. I don't even see my files in the stack trace. Can you tell me how you know it's my addon that's conflicting?
     
  17. otaku

    otaku Member

    I'm not sure. But in a thread that has let's say 5 replies and I click on the + button of the vfcoders addon I'm not getting the error. But in a "same feed thread i'm receiving the error.
     
    Last edited: Mar 9, 2014
  18. Daniel Hood

    Daniel Hood Well-Known Member

    Interesting, I'll look into it a little bit later tonight.
     
  19. otaku

    otaku Member

    Cool thanks. I want to add that I'm not receiving the error when I use last post or first unread post. It only happens when First post is enabled.

    Display First/Last Post
    • First Post
    • Last Post
    • First Unread Post
     
  20. Gazhyde

    Gazhyde Well-Known Member

    Just bought and installed this on my test kit. Seems to work really well, and gets over the headache of SPAMming certain forums.

    Any one else using this effectively on their site, or have issues with it before I roll it out to my live site?
     

Share This Page