1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 XenForo Installation problem (Error 500)

Discussion in 'Installation, Upgrade, and Import Support' started by Richey, Nov 27, 2011.

  1. Richey

    Richey Member

    Hey guys,

    I am currently using XenForo 1.0.4.
    Now that 1.1 has been released, I would like to create a fresh new installation.

    But the installation process always crashes after some time.
    I get an Error message ("An error has occurred....") and five seconds later I get an 500-Server Error.

    Can you help me?

    Thx!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Check the server error logs.

    A 500 error is fairly generic so more information will be needed to determine the cause.
     
  3. Richey

    Richey Member

    Hey Brogan,

    no success. There are now errors visible in my error log.
     
  4. Mike

    Mike XenForo Developer Staff Member

    Do you know what step it's on when that happens? It'd be the last text shown before the "error occurred" text appears.
     
  5. Richey

    Richey Member

    Hi Mike,

    the last step is:

    Rebuilding ... Templates (importing)

    after this I get

    An error occurred or the request was stopped.

    and some seconds later

    500 Interneral Server Error.

    That's really strange. I don't think that my webhosting configuration is the reason because I already run a XenForo Community on the same webhost.
     
  6. Mike

    Mike XenForo Developer Staff Member

    Is this a VPS/dedicated or a shared server?

    I can try to look into it, but a 500 ISE error with no other log is unfortunately nigh impossible to debug.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    If your intention is to "install fresh" and then copy over your old forum information then you should stop right there and do an upgrade instead:

    http://xenforo.com/help/upgrades/

    On the other hand, if you want to start over with none of your old users and posts then proceed with troubleshooting the new installation.
     
  8. Richey

    Richey Member

    Hey guys,

    thank you for the answers. I found the errror. I think it was a timeout problem.
    I upgraded my webhosting package to a shared hosting package and now it's working.

    :) Yipeeeee :)
     
    mrGTB likes this.
  9. mrGTB

    mrGTB Well-Known Member

    Now that made me laugh! :ROFLMAO:
     
  10. Alpha52

    Alpha52 Member

    I'm having a very similar issue doing an initial installation of 1.1.
    It fails at 1b when you click Begin Installation, hangs for awhile and then times out with a 500 error.
    This is simply a shared hosting package through Dreamhost and should work. Requirements are met via the PHP file check. Safe mode is off. Everything is updated.
    Permissions are 777 on both data and internal_data with the install folder at 755.

    I know it could be any one of a million things but maybe knowing exactly when it happens helps narrow it down? It connects to the SQL server fine and everything.
    Logs show nothing.

    Thanks for helping!
     
  11. mrGTB

    mrGTB Well-Known Member

    Your using shared hosting same as me, so your problem might lie in those 777 folder permissions causing the "500 internal server errors". Until Mike can answer you later, try this for now. This is the same set-up I'm using on my shared hosting. Change all folders you see using 777 to 755 instead, then change all files that's been given "755 or 777" to 644 instead. (Folders 755 | Files 644)

    Then last, open the config.php file located in the Library folder and add this new line to it.

    Code:
    $config['chmodWritableValue'] = 0644;
    ===============

    You need to keep one thing in mind though using 0644 instead of 0755 in that line of code added to congfig.php. That permission is OK given to files by XenForo, the problem is it will also do the same with "new folders" you don't "yet have created". Such as "Attachment and Avatar" folders if you've not uploaded any avatars or posted any attachments. Once you do upload Avatars and Attachment in posts for the first time, use your FTP and change permission again on those new folders XenForo generates to 755 from 644. Just follow the same rule of thumb (Folders 755 | Files 644)

    You could use 755 instead of 644 in that line of code added to the config.php to override 777 permission given, but the problem is it will then give all new files like avatars and attachments uploaded the same 755 permission as folders (if you get my drift). So it's better really to set it as 644 and just manually change XenForo folders created to 755 permission from 644. Folders only get created once anyway, so it only needs to be done once.

    Really it would be best if there was some code you add into config.php that stops XenForo from setting CHMOD permissions at all in some cases like this, leaving the server host to do it itself like mine does. Because those permissions below are exactly the same as my Server Host would configure things CHMOD wise if XenForo was not forcing any permissions on folders and files. I suspect your going to have a lot of problems with people using shared hosting the way CHMOD permissions are being done right now forced onto folders and files with the default being 777 is given.

    I've already posted a screen-shot in another thread where my server host is saying in a live discussion that 777 permission used on shared hosting with cPanel is wrong in many cases and can cause 500 internal server errors.

    Below are some images to give you an idea how permissions are setup on my shared hosting running problem free.

    01:
    01.PNG

    02:
    02.PNG

    03:
    03.PNG

    04:
    04.PNG

    05:
    05.PNG

    06:
    06.PNG

    07:
    07.PNG

    08:
    08.PNG

    09:
    09.PNG
     
    rodrigotello likes this.
  12. Alpha52

    Alpha52 Member

    Thanks so much for the help mrGTB.
    Sadly though, I still get the same problem. I changed all folders to 755 and files to 644 and added the line into the config with the same results: hangs on 1b and times out with a 500 error.
    Thanks again for the help though!
     
  13. mrGTB

    mrGTB Well-Known Member

    Some parts of the XenForo installation I've noticed can take a "fair while" to complete, I've noticed that on my shared hosting when installing XenForo before. There have been a few times here also when my install timed out because server was running sluggish at the time the install was done. But later when server seemed to be running fast and well, carrying out install again went OK without any issues.

    Not saying that will work for you, but it seems to be a thing with shared hosting. Your at the mercy of how the server is running at the time with other users on the same box.
     
  14. Alpha52

    Alpha52 Member

    I've tried it ~20 times over the past 2 days =/
     
  15. Alpha52

    Alpha52 Member

    Welp, problem has been solved. Turned out the installation was just too intensive for the little shared hosting plan. Upgraded to a managed VPS and everything worked fine :)
     

Share This Page