• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Xenforo demo

#1
Hi..

I bought XenForo some days ago but as my current forum runs VB5 and it will take some time to make everything work right. Meanwhile, I was working on the 3 days demo version to customize the template, but I created a new one today and I have facing some issues to upload my custom skin. Some server error logs are listed:

ErrorException: Fatal Error: Cannot call overloaded function for non-object - library/XenForo/DataWriter/StyleProperty.php:106

ErrorException: Argument 4 passed to XenForo_DataWriter::_isFieldValueValid() must be of the type array, null given, called in /home/xfdemo/www/130/library/XenForo/DataWriter.php on line 643 and defined -library/XenForo/DataWriter.php:718

ErrorException: Argument 4 passed to XenForo_DataWriter::_isFieldValueValid() must be of the type array, null given, called in /home/xfdemo/www/130/library/XenForo/DataWriter.php on line 643 and defined -library/XenForo/DataWriter.php:718
When I go to upload the skin it simply doesn't do anything...
 

Steve F

Well-known member
#2
Hi..

I bought XenForo some days ago but as my current forum runs VB5 and it will take some time to make everything work right. Meanwhile, I was working on the 3 days demo version to customize the template, but I created a new one today and I have facing some issues to upload my custom skin. Some server error logs are listed:

ErrorException: Fatal Error: Cannot call overloaded function for non-object - library/XenForo/DataWriter/StyleProperty.php:106

ErrorException: Argument 4 passed to XenForo_DataWriter::_isFieldValueValid() must be of the type array, null given, called in /home/xfdemo/www/130/library/XenForo/DataWriter.php on line 643 and defined -library/XenForo/DataWriter.php:718

ErrorException: Argument 4 passed to XenForo_DataWriter::_isFieldValueValid() must be of the type array, null given, called in /home/xfdemo/www/130/library/XenForo/DataWriter.php on line 643 and defined -library/XenForo/DataWriter.php:718
When I go to upload the skin it simply doesn't do anything...
The demo does not allow uploading of styles or add-ons. You should setup a test forum of your own if you have a license
 
#3
yes, it does. I was working on the demo for some days and always downloaded/uploaded the skin to continue the work...
 

Steve F

Well-known member
#4
To be honest I never tried a style import, I based my response on others from the past and may have mis-understood.

I did just try to import a style and it did not work for me but I'm also having some network issues I think as I only get a error stating "No data received".
 

Mike

XenForo developer
Staff member
#5
Can you try again? That sounds like something weird going on as that error really doesn't make sense. Sounds a bit like an opcode cache memory corruption (which is something we have seen before).
 

Steve F

Well-known member
#6
Can you try again? That sounds like something weird going on as that error really doesn't make sense. Sounds a bit like an opcode cache memory corruption (which is something we have seen before).
Not sure if that was directed at me Mike, but I was able to import a style this time.
 
Last edited: