Xenforo and CPanel - 500 Internal Error

José Guedes

Active member
Hello, I have moved my forums from my 1and1 hosting, after they messing up with us, and started using CentOS with CPanel.
But now, after making everything required for the forums to run, I get this 500 Internal Error with a 404... (http://forums.superialbuilders.com/)
Anyone knows how to fix this? I have been around this for few weeks now and I can't pull the fix out of my head...
 

Walter

Well-known member
Cpanel has nothing to do with Xenforo, should work perfectly.

Look into the error logfile that the server generates (e.g. error.log in the same directory as Xenforo) and tell us what's inside the file.
 

José Guedes

Active member
There's no error log in the same directory as XenForo. There is one of those in /usr/local/apache/logs.
In the error.log file in there, here's the latest error:
Code:
[Sun Jun 26 11:31:54 2011] [error] [client <ip>] /usr/bin/php: symbol lookup error: /usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so: undefined symbol: zend_atol, referer: http://xenforo.com/community/threads/xenforo-and-cpanel-500-internal-error.17364/
[Sun Jun 26 11:31:54 2011] [error] [client <ip>] Premature end of script headers: php5, referer: http://xenforo.com/community/threads/xenforo-and-cpanel-500-internal-error.17364/
[Sun Jun 26 11:31:54 2011] [error] [client <ip>] File does not exist: /home/altair/public_html/xen/500.shtml, referer: http://xenforo.com/community/threads/xenforo-and-cpanel-500-internal-error.17364/
[Sun Jun 26 11:31:55 2011] [error] [client <ip>] File does not exist: /home/altair/public_html/xen/favicon.ico
[Sun Jun 26 11:31:55 2011] [error] [client <ip>] File does not exist: /home/altair/public_html/xen/404.shtml
 

Brogan

XenForo moderator
Staff member
First of all, have you confirmed the server spec's meet the requirements?

XenForo System Requirements
  • PHP: 5.2.4+
  • MySQL: 5.0+
  • PHP extensions: MySQLi, GD (with JPEG support), PCRE, SPL, SimpleXML, DOM, JSON, iconv, ctype
  • PHP safe_mode off
Download the requirements test script.

I also see a reference to Suhosin there - here's a search result of all threads relating to Suhosin, it may be that your problem has already been posted about: http://xenforo.com/community/search/1051220/?q=suhosin&t=post&o=date
 

Shamil

Well-known member
The error message “php: symbol lookup error: /usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so: undefined symbol: zend_atol” occurs when an application is not compatible with Suhosin.


The only work around is to enable suhosin.simulation for the account (domain) instead of disabling Suhosin server wide.

The suhosin.simulation if turned ON, will log the violations as usual but nothing will be blocked or removed from the request.

You can perform this task in one of the either ways:
1) Enable suhosin.simulation in a .htaccess file of the domain (non-suphp enabled server)

php_flag suhosin.simulation On
OR
2) Create a php.ini file under the account (domain) and turn ON the simulation

suhosin.simulation = On
There is no need to restart any service in any of the above case.
 

José Guedes

Active member
Done both and none work...
Code:
[Sun Jun 26 16:30:40 2011] [alert] [client <ip>] /home/altair/public_html/.htaccess: Invalid command 'php_flag', perhaps misspelled or defined by a module not included in the server configuration
 

Shamil

Well-known member
Can you show us a phpinfo() by creating a file, and in it, enter:

PHP:
<?php

phpinfo();
Thanks.
 

José Guedes

Active member
Your host has disabled that functionality.
I am my own host, I fixed it...

The PHP Info file shows that suhosin.simulation is on.​
Gonna check error logs.​
It gives me some php_flag errors, I think this could be because its a CPanel installation. php is not installed as an Apache module.
 

José Guedes

Active member
Got rid of the php_flag errors.

Now when I try to go to http://forums.superialbuilders.com i get this in the error logs:

Code:
[Sun Jun 26 17:35:46 2011] [error] [client 84.90.0.34] /usr/bin/php: symbol lookup error: /usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so: undefined symbol: zend_atol
[Sun Jun 26 17:35:46 2011] [error] [client 84.90.0.34] Premature end of script headers: php5
 

José Guedes

Active member
It wasn't preinstalled or automatically installed if I hadn't selected it. I suggest you remove it, or rebuild apache with the latest PHP software / Apache.
Okay, I am rebuilding Easy Apache without Suhosin and with latest PHP 4 and 5.
 
Top