Duplicate Xenforo 2 constantly refreshing page on the Steam browser (CEF chromium embedded framework)

bottiger

Active member
Affected version
v2.2.8 Patch 1
Anyone using the Steam browser to view any Xenforo 2 forum will have the page constantly refresh every second, making it unusable. To reproduce this, you can press shift+tab in a game to open the Steam overlay, click on "view community hub" and change the url to https://xenforo.com/community

I'm guessing there's something wrong with the JavaScript that the browser doesn't like.

I know this is probably a browser specific issue but I think it is worth solving. The user agent indicates that the version of chromium is relatively recent, which probably means it is not going to be fixed simply by telling Valve to upgrade their chromium embedded framework.

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 10.0; en-US; Valve Steam GameOverlay/1642451672; ) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.105 Safari/537.36
 

Chris D

XenForo developer
Staff member

bottiger

Active member
Or there’s something wrong with the browser that the JavaScript doesn’t like 🙂

This has been reported before but given it is only an issue in this browser, we can only assume that it is a browser issue.

It’s also not exclusive to XF sites, apparently:


There's a workaround for reddit as posted in the link you have. Would it be possible to have a workaround for xenforo?
 

Chris D

XenForo developer
Staff member
No. Because the workaround for Reddit involves loading an old version of their site. We have no such thing. Valve simply need to fix their broken browser.
 
Top