1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 When using Index Page Route Under Basic Board Info...

Discussion in 'XenForo Questions and Support' started by The Dark Wizard, Nov 15, 2013.

  1. The Dark Wizard

    The Dark Wizard Well-Known Member

    And the forum index automatically switchs to blah.com/forums, how do you alter the url that the forums end up on with out using the Route Filter because doing a filter for /forums also edits the url for all the different forums since they also include the word "forums".
     
  2. Mike

    Mike XenForo Developer Staff Member

    You have to do a route for /forums. There's nothing stopping you doing a route for /forums/{name}/ as well though, which would match the latter (and you can replace it with the same thing). Only one filter matches per route.
     
  3. The Dark Wizard

    The Dark Wizard Well-Known Member

    I don't think I explained it correctly.

    When I set a page as the new index, the forum index(even though its installed in the root directly) get sent to /forums.

    However I want to change the route for nodes that are forums, and make them for example /test/ and it works, however since the nodes have the same same route as the forum index, now everything is /test/

    I was wondering it there was a way for it to tell them apart.
     
  4. Mike

    Mike XenForo Developer Staff Member

    You should just be able to do:

    /forums/{name}/ -> /test/{name}/
     

Share This Page