What am I missing?

Slavik

XenForo moderator
Staff member
To do the following as per the screenie, change the background from blue to red.

red.png

I've added this to the usergroup styling, but it 'aint working :(


Code:
.messageUserBlock a.username {
    background: url("styles/p8ntballer/xenforo/xenfocus/maintitle.png") repeat-x scroll 0 50% #CC1111;
}
 

Fuhrmann

Well-known member
Have you tried to insert !important?

Rich (BB code):
.messageUserBlock a.username {
background: url("styles/p8ntballer/xenforo/xenfocus/maintitle.png") repeat-x scroll 0 50% #CC1111 !important;
}
 

Fuhrmann

Well-known member
Try this!

Code:
.messageUserBlock a.username {
    background: #CC1111 url("styles/p8ntballer/xenforo/xenfocus/maintitle.png") repeat-x scroll 0 50% !important;
}
 

CTXMedia

Formerly CyclingTribe
I could be wrong, but doesn't ...
.messageUserBlock a.username
... mean the styling for an anchor/link of the users name? Could that be the problem - it's the wrong element?
 

Jake Bunce

XenForo moderator
Staff member
This is the relevant CSS in the source:

Rich (BB code):
.messageUserBlock a.username {
font-weight: bold;
color: white;
text-decoration: none;
padding-top: 8px;
padding-bottom: 8px;
margin: -1px;
border-top-left-radius: 3px;
-webkit-border-top-left-radius: 3px;
-moz-border-radius-topleft: 3px;
-khtml-border-top-left-radius: 3px;
border-top-right-radius: 3px;
-webkit-border-top-right-radius: 3px;
-moz-border-radius-topright: 3px;
-khtml-border-top-right-radius: 3px;
display: block;
overflow: hidden;
line-height: 16px;
text-align: center;
text-shadow: 0 0 0 transparent, 0 1px 0 rgba(0, 0, 0, 0.8);
background: #014980 url('styles/p8ntballer/xenforo/xenfocus/maintitle.png') repeat-x 0% 50%;
}
So this should work:

Admin CP -> Appearance -> Templates -> EXTRA.css

Code:
.messageUserBlock a.username
{
	background-color: red !important;
}
 

EQnoble

Well-known member
To do the following as per the screenie, change the background from blue to red.

View attachment 25455

I've added this to the usergroup styling, but it 'aint working :(


Code:
.messageUserBlock a.username {
    background: url("styles/p8ntballer/xenforo/xenfocus/maintitle.png") repeat-x scroll 0 50% #CC1111;
}
Is this supposed to be for all usergroups or one specifically?
 

EQnoble

Well-known member
if you want to use that image use this
Code:
div.messageUserBlock a.username {
 
background: url("styles/p8ntballer/xenforo/xenfocus/maintitle.png") repeat-x scroll 0 50% #CC1111;
 
}
 

Slavik

XenForo moderator
Staff member
This is the relevant CSS in the source:

Rich (BB code):
.messageUserBlock a.username {
font-weight: bold;
color: white;
text-decoration: none;
padding-top: 8px;
padding-bottom: 8px;
margin: -1px;
border-top-left-radius: 3px;
-webkit-border-top-left-radius: 3px;
-moz-border-radius-topleft: 3px;
-khtml-border-top-left-radius: 3px;
border-top-right-radius: 3px;
-webkit-border-top-right-radius: 3px;
-moz-border-radius-topright: 3px;
-khtml-border-top-right-radius: 3px;
display: block;
overflow: hidden;
line-height: 16px;
text-align: center;
text-shadow: 0 0 0 transparent, 0 1px 0 rgba(0, 0, 0, 0.8);
background: #014980 url('styles/p8ntballer/xenforo/xenfocus/maintitle.png') repeat-x 0% 50%;
}
So this should work:

Admin CP -> Appearance -> Templates -> EXTRA.css

Code:
.messageUserBlock a.username
{
background-color: red !important;
}

Whilst this works site wide, I am trying to do it per usergroup basis.

Eg Admins would be Red
Moderators blue
Premium members Grey
etc.

Any suggests?
 

Jake Bunce

XenForo moderator
Staff member
Top