1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Weird password issue

Discussion in 'XenForo Questions and Support' started by grantus, Jun 8, 2014.

  1. grantus

    grantus Active Member

    For some weird reason, when users log out, they can't login again and I have to manually reset their password. Any ideas?
  2. Mike

    Mike XenForo Developer Staff Member

    Have you changed servers or PHP versions at all?
  3. grantus

    grantus Active Member

    No. But I recently moved my forums from /forums to the root, so public_html.
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    What exactly is happening when they try to login?
  5. grantus

    grantus Active Member

    It just tells them that their password is no good. I don't know how widespread it is, but I have had a couple of members email me and ask me to reset it.
  6. Mike

    Mike XenForo Developer Staff Member

    Can you reproduce it? If not, I can only guess that they are indeed not remembering their password.

    The only known cause for people not to be able to login (getting an invalid password message) is if you downgrade to PHP 5.2, as you lose the support for more secure password storage that is part of PHP 5.3+.
  7. grantus

    grantus Active Member

    Yes, it's possible those members just forgot their passwords, but seeing how it's only happened now after I moved the forum to root, I figured it has something to do with that.

    I tried recreating it but so far everything is fine. I'm waiting to hear back from one of the members to find out exactly what the message was that he got. I'll post back here if I hear from him.

Share This Page