Weird import problem - locks up and then tries to download admin.php

RobParker

Well-known member
I'm doing an import of VB3.7.

I've got no idea what's causing this but I successfully imported my users and avatars and started on private messages. It go to 53.88% and then firefox popped up with a save dialogue for admin.php (the file is blank).

I tried to continue the import process but straight away it just tries to send me the admin.php file again.

Completely puzzled here so any advice would be great.
 

RobParker

Well-known member
Tried a fresh import and exactly the same thing again, gets to 53.88% of importing private messages and then pops up a save dialog for admin.php
 

Brogan

XenForo moderator
Staff member
How long does it take from the start of importing private messages to the 53.88%/save dialogue point?
 

RobParker

Well-known member
A few minutes, I've not timed it but I'd guess around 5 at most.

After cancelling the save prompt it still says "Import Private Messages... 53.88%" with the little animated progress bar but it's sat like that and not done anything for 10 minutes now and looks dead.
 

Brogan

XenForo moderator
Staff member
I wonder if there's something specific to one private message which is causing it to hang?
Although I can't think what.

Are you able to check the last imported message in your XenForo database and then check what would be the next message in the vB database?

That may provide some pointers.

You could also try enabling debug mode to see if any errors are thrown.
 

Luke F

Well-known member
Are you running PHP via FastCGI or similar?

This tends to happen quite often for me with nginx+php-fpm - usually when the fastcgi process crashes or dumps a load of stuff into stderr, or occasionally due to timeout. Check your server and php logs.
 

RobParker

Well-known member
All that's in my error_log file is something relating to robots.txt

Any idea which other logs I should be looking in?
 

Luke F

Well-known member
'--enable-fastcgi' is in my phpinfo file so I assume that means I am?
It doesn't.

What does Server API say near the top of phpinfo?

And is this a shared host or do you have access to the global server logs? If the latter, look at the PHP and http server logs, probably in /var/log
 

RobParker

Well-known member
It does the same thing on importing threads and posts (34.64%) which is a much bigger issue than importing private messages :-(
 

RobParker

Well-known member
My hosts are having look at it, I get the same behaviour in phpmyadmin when I try to copy a large database. It only copies the first tables and then tries to download index.php.

My hosts have extended the php execution time but that's not helped.
 

RobParker

Well-known member
Their email stated they increased the "PHP timeout time" and that does seem to have helped a bit, the import private messages died but it restarted without a problem this time and the thread/post import has gone past 35%.
 

RobParker

Well-known member
And the thread/post import died just short of 50% but managed to resume ok.

Edit: Died again at 54% and won't restart, just keeps trying to make me download admin.php :-(

Edit2: After 4 or 5 retries it's resumed.
 

RobParker

Well-known member
Well it completed importing the threads and posts but need to be refreshed something like 30 times.

Imported 53,226 items. (9 hours 17 minutes 32.66 seconds)

At least 4 hours of that was when I had to go out and wasn't here to hit refresh when it failed but that's still pretty painful.
 
Top