1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed View image bug? (logged out attachment)

Discussion in 'Resolved Bug Reports' started by calorie, Aug 3, 2010.

  1. calorie

    calorie Active Member

    BTW, nice that [list] keeps the spacing.
  2. calorie

    calorie Active Member

    wannabe likes this.
  3. Mike

    Mike XenForo Developer Staff Member

    The trailing slash is actually correct. What browser?

    Can you use a HTTP header inspector to see what cookies are being sent with the request?
  4. calorie

    calorie Active Member

    Live HTTP headers output...
    GET /community/attachments/8-3-10-10-08-55-am-gif.307/ HTTP/1.1
    Host: xenforo.com
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20100701 Firefox/3.5.11 ( .NET CLR 3.5.30729)
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 300
    Connection: keep-alive
    Referer: http://xenforo.com/community/threads/view-image-bug.1042/
    Cookie: foro_session=<removed>; foro_user=271%<removed>
    If-Modified-Since: Tue, 03 Aug 2010 18:09:58 GMT
    HTTP/1.1 304 Not Modified
    Date: Tue, 03 Aug 2010 20:52:13 GMT
    Server: Apache/2.2.3 (Red Hat)
    Connection: close
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: private, max-age=0
    Other attachments I'm able to view.
  5. Mike

    Mike XenForo Developer Staff Member

    If you go to the URL where you got an error and hard refresh (ctrl+f5), does it work then? Wondering if it's a 304 not modified issue...
  6. fattony69

    fattony69 Well-Known Member

    Oddly enough, both work for me.
  7. calorie

    calorie Active Member

    Hmm, I could have sworn I hard refreshed before starting this thread, just to be sure I was getting what I was getting, but I didn't hard refresh when getting the headers, so that explains the 304 not modified. Refreshing again just now does show that image. No more error message. Sorry for the report. :oops:
  8. Msharry

    Msharry Active Member

    hard refresh works! but you need to do it every time.

    FF 3.6.8 Win 7 x64.
  9. erich37

    erich37 Well-Known Member

  10. kyrgyz

    kyrgyz Well-Known Member

    Not happening to me. Tried twice. I am still logged in.
  11. Floris

    Floris Guest

  12. Brogan

    Brogan XenForo Moderator Staff Member

    What OS and browser are you using?

    I have tried with Win 7 + FF, IE8 and Chrome and Vista + FF, IE7 and Chrome and haven't come across that problem (yet).
  13. Biker

    Biker Well-Known Member

    No issues here.
  14. erich37

    erich37 Well-Known Member

    Win XP and latest FF-browser.
    The issue is only showing for this specific attachment, others are fine.
  15. Brogan

    Brogan XenForo Moderator Staff Member

    Try clearing your cache.
    It might just be a local issue.
  16. Mike

    Mike XenForo Developer Staff Member

  17. richyrich

    richyrich Member

    I just had a similar issue trying to view this image http://xenforo.com/community/attachments/screen-shot-2010-07-31-at-04-35-35-png.104/

    Try to recreate:-
    View forum (not logged in)
    Browsed to this thread http://xenforo.com/community/threads/xenforo-overview.567/
    Clicked link in Section 9 - SMTP (More Information)
    Attempted to open image in Post 2 (Still not logged in)
    Opens login page in new tab
    Try logging in and get login / security error (Shows correct user details in top nav bar though)
    Close new tab and refresh original thread page
    Shows correct user details in top nav bar ( viewImage1.jpg )
    Try clicking on image again and get login page. ( viewImage2.jpg )
    Try logging in again and shows login error ( viewImage3.jpg )

    OS - Windows XP
    Browser - FF 3.6.8
  18. Caliburn

    Caliburn Well-Known Member

    Still running into this issue in Mozilla Firefox 3.6.8 - *Hard Refresh* doesn't work for me. No idea.
  19. Mike

    Mike XenForo Developer Staff Member

    This should be fixed now. Please let me know if you have any issues with it.
  20. Msharry

    Msharry Active Member

    Works fine for me now.

    Thanks Mike.

Share This Page