1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 user group promotions

Discussion in 'XenForo Questions and Support' started by gavpeds, Jul 8, 2014.

  1. gavpeds

    gavpeds Active Member

    I need a little help.

    I have three user groups registered, full member and elite member.

    Have i set this correct as full members once they hit 2000 posts are getting dropped to registered member instead of being promoted to elite member as intended

    If i remove the "user has posted no more than 2000 in full member users stay as full members but are not promoted to elite members.

    Full member promotion criteria
    full member.png

    Elite member criteria
    elite member.png
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Are there any other criteria for the elite member user group?
     
  3. Martok

    Martok Well-Known Member

    You'll have to set "User has posted no more than X messages" to 1999. Setting it to 2000 means that when this does work, when they reach 2000 posts they would be in both the full members group and elite group. They would only leave the full members group once they hit 2001 posts if you set it to 2000.

    Are you sure that those not getting promoted have met the other criteria for the elite group i.e. they have at least 50 likes, 60 trophy points and have been registered for at least 182 days? Also as Brogan says, are there any other criteria set that you haven't told us about?
     
    Last edited: Jul 8, 2014
  4. gavpeds

    gavpeds Active Member

    Nope, both groups the only criteria is as above.

    Changed the "user has posted no more than" to 1999. Run the cron and rebuild cache but full members that meet all the criteria for elite are still getting dropped to registered instead of being promoted to elite. I am aware this needs users to be recently active to be promoted but some of those users have been active in the last hour or so.
     
    Last edited: Jul 8, 2014
  5. gavpeds

    gavpeds Active Member

    Ok so it seems to now be working after i entered a user banner text for the elite member group which i forgot to do.

    Just one more question re groups. Is there anyway i can set up a group which will not allow links to be posted?

    I was wondering if i could have an initial group that new users are in which does not allow links in posts?
     
  6. Martok

    Martok Well-Known Member

    Maybe they were being promoted as expected but because you had no banner, it looked like they weren't in the elite group?

    No, there is no permission controlling links in posts. You could always set up newly registered to be moderated for say the first 5 posts if you're concerned about spammers.
     
  7. gavpeds

    gavpeds Active Member

    Thanks, yes i think that is what must have been happening. I dont have to many issues with spam but just forward thinking. I have contemplated manual approval. But wonder if that would put new users of. I know for myself if i was hunting forums and wanting a question answered. Often if i had to wait for my posts to be moderated i would just go to another forum and get the answer without moderation. Will have to think about that, but as i say spam is not to much of an issue at the moment.
     
  8. TerryP

    TerryP Member

    Through this add-on, you may be able to accomplish that...I've used the "allow" to disable those items for banned users on my forums. You'll have to search the RM to find the add-on.

    1.png
     

Share This Page