XF 1.2 uploading avatars error?

C.Stanley

Active member
When a member tries to upload a avatar they get this avatar.PNG

Then in ACP i see
avatar1.PNG
Avatar permissions are set "unlimited" size.

Any help would be great
 

C.Stanley

Active member
Code:
ErrorException: mkdir(): Permission denied - library/XenForo/Helper/File.php:68
Generated By: SPEED, 9 minutes ago
Stack Trace
#0 [internal function]: XenForo_Application::handlePhpError(2, 'mkdir(): Permis...', '/home/globalha/...', 68, Array)
#1 /home/globalha/public_html/forums/library/XenForo/Helper/File.php(68): mkdir('/home/forumedi/...')
#2 /home/globalha/public_html/forums/library/XenForo/Model/Avatar.php(335): XenForo_Helper_File::createDirectory('/home/forumedi/...', true)
#3 /home/globalha/public_html/forums/library/XenForo/Model/Avatar.php(206): XenForo_Model_Avatar->_writeAvatar(112, 'l', '/home/globalha/...')
#4 /home/globalha/public_html/forums/library/XenForo/Model/Avatar.php(69): XenForo_Model_Avatar->applyAvatar(112, '/tmp/phpT1laXY', 2, 225, 225, Array)
#5 /home/globalha/public_html/forums/library/XenForo/ControllerPublic/Account.php(548): XenForo_Model_Avatar->uploadAvatar(Object(XenForo_Upload), 112, Array)
#6 /home/globalha/public_html/forums/library/XenForo/FrontController.php(337): XenForo_ControllerPublic_Account->actionAvatarUpload()
#7 /home/globalha/public_html/forums/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 /home/globalha/public_html/forums/index.php(13): XenForo_FrontController->run()
#9 {main}
Request State
array(3) {
["url"] => string(49) "http://globalhax.com/forums/account/avatar-upload"
["_GET"] => array(0) {
}
["_POST"] => array(8) {
["use_gravatar"] => string(1) "0"
["avatar_date"] => string(1) "0"
["avatar_crop_x"] => string(1) "0"
["avatar_crop_y"] => string(1) "0"
["_xfToken"] => string(8) "********"
["_xfNoRedirect"] => string(1) "1"
["_xfResponseType"] => string(9) "json-text"
["_xfUploader"] => string(1) "1"
}
}
 

Bionic Rooster

Well-known member
I could be wrong but it looks to me like file permission for the data folder is not set to make a new avatar directory. With an ftp program check the data folder permissions. Out of the box it was set to 777
 

C.Stanley

Active member
I could be wrong but it looks to me like file permission for the data folder is not set to make a new avatar directory. With an ftp program check the data folder permissions. Out of the box it was set to 777
Data folder is on 755. So change it it 777?
 

Bionic Rooster

Well-known member
I'd try it to see if it makes a difference for you, if it doesn't you can always put it back, but it looks like 755 denies 2 writing permissions.
 

C.Stanley

Active member
The only avatar permissions are the ones in usergroup settings correct?

I will give access if someone cares to take a look.
 
Top