1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server Issue Uploading attachment size

Discussion in 'Resolved Bug Reports' started by Koevoet, Nov 28, 2010.

  1. Koevoet

    Koevoet Member

    I am having issues uploading attachments over 1.5MB onto my xen forum , the attachment size has been altered in the ACP to accomodate the new sizes , the file seems to upload 100% then i get the following error "The uploaded file is too large for the server to process."

    The appropriate permissions have also been set in the ACP for all users and user groups.
    The attachments folder in the internal data folder has been chmod to 777 as well

    Does any one have any insight to these issues and how they can be resolved.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    What have you actually set your attachment settings to?
    Can you do a screenshot or list them here?

    Does your host have any limits set in php?

    You could try contacting them to see if that's the case.
  3. Koevoet

    Koevoet Member

    Thanks for the reply
    Spoken to host there is no lmits set as he has a few VB sites running as well and they have no upload issues
    Attached are the screenshots of the att. size in ACP options and Admin permissions
    28-11-2010 15-43-38.png

    28-11-2010 15-44-40.png
  4. Brogan

    Brogan XenForo Moderator Staff Member

    I've just tested this on my local install and was able to upload a 6MB attachment using your settings.

    It could just be something related to your install/server, I'll have to do a bit more digging.
  5. Koevoet

    Koevoet Member

    I increased the size limit to the above just as a precaution to make sure , the file itself i was trying to upload is only 2.04MB in size , i have decreased the limit as well and it then shows the file attachment is too large (as suspected) , but it just will not load it fully with the correct settings .
  6. Mike

    Mike XenForo Developer Staff Member

    As the error says, the file is too big for the server to handle; the file is being rejected before XF even gets it. You need to increase one of several settings. It's most likely your upload_max_filesize value in PHP.

    You can likely add this to your .htaccess file:

    php_value upload_max_filesize 8M

    And try again.
  7. Koevoet

    Koevoet Member

    Thx for the reply , i seemed to have it solved now .

    I added what you proposed to the .htaccess file , but that did not work , so i created a php.ini file and altered the upload_max_filesize value and added that to the root folder. This seems to have solved the issue.

    Thx once again

Share This Page